В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
KIMSEOLHYUN
KIMSEOLHYUN
19.10.2020 14:24 •  Информатика

50 заданы две точки на плоскости х у . составьте программу определяющую какая из них находится ближе к началу кординаткой плоскости. и так далее (только так напишите )

Показать ответ
Ответ:
musinalarisa
musinalarisa
08.10.2020 16:21
Program graph;
var
x1,y1,x2,y2, a, b: real;
begin
  writeln('Введите координаты первой точки: ');
    readln(x1,y1);
  writeln('Введите координаты второй точки: ');
    readln(x2,y2);
a:=(sqr(x1) + sqr(y1));
b:=(sqr(x2) + sqr(y2));
   if a < b then
      writeln('Первая точка ближе к началу кординаткой плоскости')
    else if a > b then
      writeln('Вторая точка ближе к началу кординаткой плоскости')
    else
      writeln('Обе точки равноудалены')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота