В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
svetlanaivanova3
svetlanaivanova3
18.09.2021 15:49 •  Информатика

5. Составьте программу вычисления и вывода на экран степеней числа А с натуральным
показателем от 1 до n т.е. А^1, А^2, А^3,..., А^N".
В quick basic

Показать ответ
Ответ:
danilka107
danilka107
31.05.2020 05:51
Var
  a,b,h,x,y:real;
label M;
begin
  Write('Введите a,b,h :');
  Read(a,b,h);
  x:=a;
M:
  if x<=b+h/2 then begin
    y:=2*Sqr(Sin(x))+1;
    Writeln(x:12:7,y:18:7);
    x:=x+h;
    goto M
    end
end.

Пример
Введите a,b,h :-5 4 0.2
  -5.0000000         2.8390715
  -4.8000000         2.9846879
  -4.6000000         2.9748436
  -4.4000000         2.8110930
  -4.2000000         2.5192887
  -4.0000000         2.1455000
  -3.8000000         1.7487402
  -3.6000000         1.3916487
  -3.4000000         1.1306025
  -3.2000000         1.0068151
  -3.0000000         1.0398297
  -2.8000000         1.2244341
  -2.6000000         1.5314833
  -2.4000000         1.9125010
  -2.2000000         2.3073329
  -2.0000000         2.6536436
  -1.8000000         2.8967584
  -1.6000000         2.9982948
  -1.4000000         2.9422223
  -1.2000000         2.7373937
  -1.0000000         2.4161468
  -0.8000000         2.0291995
  -0.6000000         1.6376422
  -0.4000000         1.3032933
  -0.2000000         1.0789390
   0.0000000         1.0000000
   0.2000000         1.0789390
   0.4000000         1.3032933
   0.6000000         1.6376422
   0.8000000         2.0291995
   1.0000000         2.4161468
   1.2000000         2.7373937
   1.4000000         2.9422223
   1.6000000         2.9982948
   1.8000000         2.8967584
   2.0000000         2.6536436
   2.2000000         2.3073329
   2.4000000         1.9125010
   2.6000000         1.5314833
   2.8000000         1.2244341
   3.0000000         1.0398297
   3.2000000         1.0068151
   3.4000000         1.1306025
   3.6000000         1.3916487
   3.8000000         1.7487402
   4.0000000         2.1455000
0,0(0 оценок)
Ответ:
МарусяЧешир
МарусяЧешир
04.02.2023 17:21
Рисуй дерево.
смотри, каждая, кроме В, используется любое количество раз..
значит В (первая буква) идут стрелки (а) (с) (д) (е) (ф)(вторая буква)
из каждой буквы идёт ещё стрелки из а идет стрелок (а) (с) (д) (е) (ф)
из с идет а) (с) (д) (е) (ф)
из д идет а) (с) (д) (е) (ф)
из е идет а) (с) (д) (е) (ф)
из ф идет а) (с) (д) (е) (ф) (это третья буква)
осталась ещё одна буква и также из каждой буквы идут все, кроме В потому что В используется один раз и она у нас на первом месте.

это мы посчитали сколько слов можно составить с буквой В
теперь также, но с другими буквами. не забывай что В используется один раз
потом всё складываешь и вот тебе ответ
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота