В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
olyarogova
olyarogova
28.09.2022 11:06 •  Информатика

5 Самостоятельно: Написать программу, которая по введенной температуре выводит сообщения: «На улице холодно», «На улице прохладно», «На улице тепло», «На улице
жарко».

Показать ответ
Ответ:
Gsjhcf
Gsjhcf
01.12.2021 15:21

1. Для записи алгоритмов используют несколько словесный

графический

программный

Словесный – это записи алгоритма на естественном языке, но с тщательно отработанным набором слов и фраз, не допускающих повторений, синонимов, двусмысленности, лишних слов. Допускается использование математических символов. При графическом описания алгоритма осуществляется с блок-схем. Программный это запись алгоритма на языке программирования (в виде компьютерной программы).

2. Налить 9 литров. Перелить в другое ведро 5 литров. В 9-ти литровом останется 4 литра. Из 5-ти литрового вылить воду. Перелить из 9-ти литрового оставшиеся 4 литра в 5-ти литровое ведро. Наполнить 9-ти литровое ведро водой. Перелить в 5-ти литровое ведро 1 литр (больше в 5-ти литровое не влезет). Из 5-ти литрового вылить воду. В 9-ти литровом останется 8 литров. Перелить в 5-ти литровое ведро. ИТОГ: в 9-ти литровом останется 3 литра.

3. Прямоугольник - блок вычислений

Ромб - условие

Параллелограмм - блок ввода-вывода данных

овал - начало и конец алгоритма

Стрелки, соединяющие эти фигуры, и задают порядок выполнения действий.

0,0(0 оценок)
Ответ:
Kotya005
Kotya005
27.02.2020 11:14

Программа:

Python:

5)

from random import randint

arr = [randint(-10, 10) for i in range(10)]

print(arr[::-1])

7)

from random import randint

arr = [randint(-10, 10) for i in range(10)]

arr1_sum_plus = arr1_sum_minus = arr1_ser_plus = arr1_ser_minus = arr1_plus = arr1_minus = 0

for i in arr:

   if i > 0:

       arr1_sum_plus += i

       arr1_plus += 1

   if i < 0:

       arr1_sum_minus += i

       arr1_minus += 1

arr1_ser_plus = arr1_sum_plus / arr1_plus

arr1_ser_minus = arr1_sum_minus / arr1_minus

for i in range(10):

   arr[i] = arr[1] * 2

arr2_sum_plus = arr2_sum_minus = arr2_ser_plus = arr2_ser_minus = arr2_plus = arr2_minus = 0

for i in arr:

   if i > 0:

       arr2_sum_plus += i

       arr2_plus += 1

   if i < 0:

       arr2_sum_minus += i

       arr2_minus += 1

arr2_ser_plus = arr2_sum_plus / arr2_plus

print('Сума додатних елементів змінилася на:', arr2_sum_plus - arr1_sum_plus)

print("Сума від'ємних елементів змінилася на:", arr2_sum_minus - arr1_sum_minus)

print('Середнє арифметичне додатних елементів змінилося на:', arr2_ser_plus - arr1_ser_plus)

print("Середнє арифметичне від'ємних елементів змінилося на:", arr2_ser_minus - arr1_ser_minus)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота