В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
AnjelikaM1
AnjelikaM1
12.10.2022 15:04 •  Информатика

5.Программа получает на вход натуральное число N (1 ≤ N ≤100). Выведите на экран таблицу размером NxN, заполненную по следующему правилу: по краям таблицы стоят 0, а в середине X. Язык Питон

Показать ответ
Ответ:
genchane
genchane
14.10.2020 23:19

n = int(input())

a = [['0'] * n for i in range(n)]

for i in range(1, n-1):

    for j in range (1, n-1):

         a[i][j] = 'X'

for l in a:

    print(*l)

Объяснение:

Сначала программа получает число, и создает двумерный массив NxN, заполненный нулями. Затем идет цикл, который заполняет иксами все, кроме боковых сторон

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота