В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
6811694978ффф
6811694978ффф
24.10.2020 19:04 •  Информатика

5. Напишите программу, которая заполняет массив из 10 элементов случайными числами на отрезке
[-2; 2] и находит произведение ненулевых элементов ​

Показать ответ
Ответ:
Ladylia
Ladylia
11.10.2020 15:47

C# 8.0:

using System;

using System.Linq;

...

var Arr = RandomIntArr(-2,2,10);

Console.WriteLine(Arr.Where(x=>x!=0).Aggregate((x,y)=>x*y));

...

static int[] RandomIntArr(int Min, int Max, int ArrLen) {

   Random rnd = new Random();

   int[] Out = new int[ArrLen];

   for (int i = 0; i < ArrLen; i++)  Out[i] = rnd.Next(Min, Max+1);

   return Out;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота