В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ttania4444
ttania4444
23.03.2020 16:43 •  Информатика

5. дан двумерный массив целых чисел. составить программу, которая определяет, есть ли в некотором столбце массива хотя бы один элемент, кратный заданному числу.

Показать ответ
Ответ:
MOKOV07
MOKOV07
09.10.2020 12:12
PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var (m, n) := ReadInteger2('Количество строк и столбцов в массиве:');

 Writeln('*** Исходный массив ***');

 var a := MatrRandom(m, n, -99, 99);

 a.Println(4);

 Writeln(4 * a.ColCount * '-');

 var nCol := ReadInteger('В каком столбце ищем?');

 var C := ReadInteger('На кратность чему проверить?');

 if a.Col(nCol - 1).Any(t -> t mod C = 0) then

   Writeln('Есть такие элементы')

 else Writeln('Таких элементов нет')

end.


5. дан двумерный массив целых чисел. составить программу, которая определяет, есть ли в некотором ст
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота