5. Что такое MS Office? А) прикладная программа
В) системная программа
С)_пакет офисных приложений для ОС Windows и MacOS
D) база данных
В заданиях 6-15 Вам необходимо решить задачу.
7. Переведите число 257 из десятичной системы счисления в троичную систему
счисления. Сколько значащих нулей содержит полученное число?
A) 5
B) 4
C) 3
D) 2
8. У исполнителя «Умник 1.0» две команды, которым присвоены номера:
1. умножь на 4
2. вычти 3
Первая из них увеличивает число в 4 раза, вторая — уменьшает число на экране на 3.
Составьте алгоритм получения из числа 1 числа 49, содержащий не более 5 команд.
A) 11112
B) 11111
C) 11212
D) 12112
9. Файл размером 2500 Кбайт передаётся через некоторое соединение в течение 2
минут. Определите размер файла (в Кбайт), который можно передать через это
соединение за 240 секунд.
A) 3600
B) 3650
C) 4500
D) 5000
10. В шкафу лежат красные и желтые носки. Число красных и число желтых носков
одинаково. Известно, что минимальное число носков, чтобы из них заведомо можно
было составить по крайней мере одну пару носков одинакового цвета, совпадает с
минимальным числом носков, которые требуется взять из ящика, чтобы из них можно
было составить по крайней мере одну пару носков разного цвета. Сколько носков в
шкафу
A) 8
B) 6
C) 4
D) 10
11. Имеет ли решение следующая задача:
«Перед вами четыре ложных утверждения
2 + 2 = 5
5 * 2 = 11
6 - 1 = 5
7 + 2 = 10
Назовите их»?
А) да, действительно здесь 4 ложных утверждения, которые мы можем назвать
В) не совсем, ложных утверждений здесь 3
С) здесь только 2 ложных утверждения
D) здесь совсем нет ложных утверждений
12. Переведите числа 35, 70, 197, 287 в троичную систему счисления. Числом с
наибольшим количеством значащих нулей будет число...
А) 35
В) 70
С) 197
D) таких чисел больше одного
13. Переведите числа 35, 70, 200, 350 в двенадцатиричную систему счисления. Сколько
из полученных чисел будут содержать цифры, обозначаемые латинскими буквами?
А) 4
В) 3
С) 2
D) 1
15. Для передачи данных по каналу связи используется 5-битовый код. Сообщение со-
держит только буквы А, Б и В, которые кодируются следующими кодовыми словами:
A – 11111, Б – 00011, В – 00100.
При передаче возможны помехи. Однако некоторые ошибки можно попытаться
исправить. Любые два из этих трёх кодовых слов отличаются друг от друга не менее
чем в трёх позициях. Поэтому если при передаче слова произошла ошибка не более чем
в одной позиции, то можно сделать обоснованное предположение о том, какая буква
передавалась. (Говорят, что «код исправляет одну ошибку».) Например, если получено
кодовое слово 10111, считается, что передавалась буква А. (Отличие от кодового слова
для А только в одной позиции, для остальных кодовых слов отличий больше.) Если при-
нятое кодовое слово отличается от кодовых слов для букв А, Б, В более чем в одной
позиции, то считается, что произошла ошибка (она обозначается как «x»).
Получено сообщение: 00110 00000 11111 11010. Декодируйте это сообщение.
А) ВAАх
В) ВВАх
С) AAАх
D) AВАх
x:real;
arr2: array [1..4,1..6] of integer;
arr1: array [1..4] of integer;
begin
writeln('Введи число для сравнения');
readln(x);
for var i:=1 to 4 do
begin
writeln('Вводим строку ',i);
for var j:=1 to 6 do
begin
writeln('Введи число ', j);
readln(arr2[i,j]);
if arr2[i,j]>x then arr1[i]:=arr1[i]+1;
end;
end;
writeln('Двумерный массив: ', arr2, ' Количество чисел больше заданного: ', arr1);
end.
uses crt;
var a,i,j,n:integer;
begin
writeln('ВВедите кол. конфет в (кг)');
read(a);
n:=0;
if a>=10 then begin n:=n+ a div 10; a:=a-(a div 10*10); end;
if (a>=5) and (a<10) then begin n:=n+ a div 5; a:=a-(a div 5*5); end;
if (a>=1) and (a<5) and (a<10) then begin n:=n+ a div 1; a:=a-(a div 1*1); end;
writeln('Общее количество коробок = ',n);
end.
2 задача
uses crt;
var a,i,j,n:integer;
begin
writeln('Введите кол. суток');
read(a);
writeln('Количество часов в ',a,' сутках = ',a*24);
writeln('Количество минут в ',a,' сутках = ',a*24*60);
writeln('Количество секунд в ',a,' сутках = ',a*24*60*60);
end.