В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
irinkaff1
irinkaff1
09.06.2022 12:29 •  Информатика

4. Напишите программу, которая с переменной логического типа определяет, является ли число N, введённое с клавиатуры, отрицательным.​

Показать ответ
Ответ:
ershvik781
ershvik781
28.02.2020 13:02

440

Определим количество символов в алфавите, которым кодируется пароль. По условию он состоит из 10 букв, 10 цифр ( от 0 до 9 ) и 5 специальных символов. Итого N=10+10+5 = 25

Определим информационный объем одного символа  i из формулы N=2^i  По условию все символы кодируют одинаковым и минимально возможным количеством бит.  

2⁴ ≤ i ≤ 2 ⁵   ⇒ i= 5 бит

Пароль состоит из 10 символов, значит его объем I = i*k= 5*10 = 50 бит, но по условию задачи на хранение как пароля, так и дополнительных сведений отведено одинаковое для каждого пользователя целое количество байт. Ближайшее к 50 число кратное 8 равно 56.

таким образом информационный объем пароля I = 56/8=7 байт

Но так как по условию  для хранения пароля выделено в байтах в 1,5 раза меньше памяти, чем для хранения дополнительных сведений, то  размеры  пароля и дополнительных сведений в соотношении  1 к 1,5

верны при значениях 8 и 12 байт  

Итого на одного пользователя выделено 8+12 = 20 байт

Для 22 пользователей: 22*20= 440 байт

Объяснение:

0,0(0 оценок)
Ответ:
MrCony
MrCony
04.08.2022 05:38

1) #include <iostream>

using namespace std;

int main()

{

double a, b, c;

cin>>a;

cout<<endl;

cin>>b;

cout<<endl;

cin>>c;

cout << "Среднее: " << (a+b+c)/3 << endl;

cout << "Разность: " << 2 * (a + c) - 3 * b << endl;

}

2) #include <iostream>

using namespace std;

int main()

{

int arr[4], max = 0;

for (int i = 0; i < 4; i++)

{

cin >> arr[i];

if(max < arr[i] && arr[i] % 2 == 0)

{

max = arr[i];

}

}

if (!max)

{

cout << "Not found";

}

else

{

cout << "Max: " <<max;

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота