4. Написать программу решения данной задачи: даны длины катетов прямоугольного треугольника А и В; длины сторон прямоугольника Си D. Определить чья площадь меньше?
5. Для прохождения во второй тур олимпиады по предмету необходимо набрать F . В первом
туре давались 4 задачи, каждая оценивалась соответственно в ли
ученик во второй тур?
using System;
namespace restless
{
class Program
{
static void Main()
{
int x = Convert.ToInt32(Console.ReadLine());
int _counter = x.ToString().Length;
bool IsEven = (x & 1) == 0 ? true : false;
if (_counter == 1 && IsEven)
Console.WriteLine("Четное однозначное число");
else if (_counter == 1 && !IsEven)
Console.WriteLine("Нечётное однозначное число");
else if (_counter == 2 && IsEven)
Console.WriteLine("Чётное двузначное число");
else if (_counter == 2 && !IsEven)
Console.WriteLine("Нечётное двузначное число");
else if (_counter == 3 && IsEven)
Console.WriteLine("Чётное трехзначное число");
else if (_counter == 3 && !IsEven)
Console.WriteLine("Нечётное трехзначное число");
}
}
}
Пчелиная напасть
Жил я в детстве в деревне. Всем был доволен: и рекой, и лесом, и полной свободой.
У хозяина дома, в котором мы жили, было несколько ульев с пчёлами. Пчёлы - миролюбивые существа, если их не обижать. И верно: наши пчёлы никого не кусали, не трогали.
Никого, кроме меня. Стоило мне выйти из избы, как какая-нибудь пчела обязательно меня укусит. А бывали дни, когда меня жалили и по нескольку раз.
- Балуешься ты много, - говорила мать, - вот они тебя и кусают.
- Не балуюсь, — оправдывался я. — Совсем их не трогаю.
Время шло, и не было дня, чтобы я избежал этой пчелиной напасти.
Хотел я спросить нашего хозяина, почему пчёлы меня не любят, но побоялся. А вышло так, что я всё равно не избежал разговора с хозяином.