4. написать программу, которая вводит массив из n целых чисел и выводит на экран сам массив и сумму всех его элементов. протестировать программу на следующих массивах: а) 1 3 4 -2 б) 0 1 -2 10 11 12 -10 -3 в) 1 1 1 1 -1 -1 -1 -1
Program n1; const n=10; var a: array [1..n] of integer; i,sum: integer; begin sum:=0; for i:=1 to n do begin write('введите ',i,' число: '); readln(a[i]); end; writeln('массив: '); for i:=1 to n do begin sum:=sum+a[i]; write(a[i],' '); end; writeln; writeln('сумма: ',sum); end.
const n=10;
var a: array [1..n] of integer;
i,sum: integer;
begin
sum:=0;
for i:=1 to n do
begin
write('введите ',i,' число: ');
readln(a[i]);
end;
writeln('массив: ');
for i:=1 to n do begin
sum:=sum+a[i];
write(a[i],' ');
end;
writeln;
writeln('сумма: ',sum);
end.