В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Trdfgg
Trdfgg
06.10.2020 11:38 •  Информатика

3составить программу, выводящую время года в зависимости от номера месяца введенного пользователем.

Показать ответ
Ответ:
Yaryycher
Yaryycher
28.09.2020 18:59
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  case ReadInteger('Номер месяца (1-12):') of
  1,2,12:Writeln('Зима');
  3..5:Writeln('Весна');
  6..8:Writeln('Лето');
  9..11:Writeln('Осень');
  else Writeln('Неверный номер месяца')
  end
end.

Вариант "для школьников"
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
var n:integer;
begin
  Write('Номер месяца (1-12): '); Read(n);
  case n of
  1,2,12:Writeln('Зима');
  3..5:Writeln('Весна');
  6..8:Writeln('Лето');
  9..11:Writeln('Осень');
  else Writeln('Неверный номер месяца')
  end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота