В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

30 напишите программу, которая в последовательности натуральных чисел определяет самое маленькое число в последовательности, кратное 4 и оканчивающихся на 6 программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 4 и оканчивающееся на 6 количество чисел не превышает 100 введённые числа по модулю не превышают 300 программа должна вывести одно число: определяет самое маленькое число в последовательности, кратное 4 и оканчивающихся на 6 пример работы программы: входные данные выходные данные 16 5 56 25 16 46 36

Показать ответ
Ответ:
MrLux123
MrLux123
25.05.2020 05:35

var a,n,i,max:integer;

begin

readln(n);

readln(max);

for i:=1 to n-1 do

     begin

     readln(a);

 if ((a< max) and (a mod 4 = 0) and (a mod 10 = 6)) then

        begin

        max:=a;

  end

 

     end;

writeln(max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота