В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
crazy660
crazy660
28.04.2022 23:35 •  Информатика

3.составить программу, которая устанавливала бы, является ли четырёхугольник со сторонами a, b, c, d параллелограммом. нужно

Показать ответ
Ответ:
diassultanov1
diassultanov1
08.10.2020 11:31
Pascal :
Код чтобы скопировать : http://rextester.com/EFBKO81416

3.составить программу, которая устанавливала бы, является ли четырёхугольник со сторонами a, b, c, d
0,0(0 оценок)
Ответ:
Yaklaura
Yaklaura
08.10.2020 11:31
Язык C++.
#include < iostream >
using namespace std;
int main(){
int a, b, c, d, u;
cout << "Все четыре угла прямые (Да - 1/Нет - 0)?" << endl;
cin >> u;
switch(u){
case 0:{
cout << "Введите длины сторон: " << endl;
cin >> a >> b >> c >> d;
if((a==c && d == b) && (a==b && c==d)&&(a==d && b==c) &&(c==b && a == d))
cout << "Не параллелограмм";
else if((a==c && d == b) || (a==b && c==d)||(a==d && b==c) || (c==b && a == d))
cout << "Параллелограмм";
else
cout << "Не параллелограмм";
break;
}
case 1:{
cout << "Не параллелограмм";
}
}
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота