Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
ebotalov
26.02.2022 20:30 •
Информатика
3. Напишите программу вычисления количество и суммы чисел кратных 3, в диапазоне 0…100. (Pascal)
Показать ответ
Ответ:
bereza11
20.06.2022 23:12
#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int n,sum=0;
float y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
if (mass[i] >0 )
{
k++;
y=pow(mass[i],2);
cout<<y;
sum+=mas[i]
}
}
system("pause");
}
2)#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
0,0
(0 оценок)
Ответ:
kril20101
18.09.2021 08:02
//я писал этот унылый код полтора часа. Полтора часа, Карл! Я слишком расслабился.
#include <iostream>
using namespace std;
int k=2;
bool StrangeSeq(int n){
if (k<n){
if(n%k==0){
cout<<"false";
return false;
}
k++;
StrangeSeq(n);
}
else
{
cout<<"true";
return true;
}
}
int main(){
int n;
cin>>n;
StrangeSeq(n);
cin.get();
cin.get();
}
0,0
(0 оценок)
Популярные вопросы: Информатика
адамчик2
14.03.2021 14:58
Дима решил посчитать, сколько у него наград за n лет. у него награды разложены по и известно их количество. формат ввода: n – количество лет (n =25) a[1] – количество...
qoqo5
10.07.2020 03:28
Составить алгоритм и программу. -23 ; 15 ; 32 ; 0 ; -56 ; 87 ; 7 - массивы. посчитать кол-во элементов массива ,которые больше нуля...
krayushkinaalina
11.03.2021 07:01
Дается последовательность из n чисел. найдите количество различных чисел. формат входных данных первая строка входного файла содержит целое число n (1 = n = 1000000)....
meimanby
15.09.2020 07:28
Как связано имя джорджа буля со словами и,или...
КаМиЛлА2911
11.04.2023 17:39
Кто нибудь у меня в вк весь порядок песен каким то образом сбился ! нет , они все по порядку идут , а когда включаю , что идут не о порядку что нужно сделать , чтобы...
Yotuberik
11.04.2023 17:39
Представить числа в машинном коде: 819 -278...
Zeus41
11.04.2023 17:39
9класс ! напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел. программа получает на вход целые числа, количество...
людмила245
11.04.2023 17:39
Два текста содержат одинаковое количество символов. первый текст составлен в алфавите мощностью-32 символа, второй мощностью-64 символа. во сколько раз отличаются информационные...
fafab232
11.04.2023 17:39
Вpaint выбран синий цвет линий и красный цвет фона. рисунок-зелёный шар на желтом фоне. выбрав инструмент ластик мы хотим сделать в шаре дырку. вопрос -какого цвета она...
hopik2
04.10.2020 18:56
)выполните перевод единиц измерения количества информации. 1) 0,25 мбайт = кбайт 2) 10240 бит = кбит 3) 236 бит = гбайт ii) впишите формулу, устанавливающую связь мощности...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <cmath>
using namespace std;
void main()
{
int n,sum=0;
float y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
if (mass[i] >0 )
{
k++;
y=pow(mass[i],2);
cout<<y;
sum+=mas[i]
}
}
system("pause");
}
2)#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
#include <iostream>
using namespace std;
int k=2;
bool StrangeSeq(int n){
if (k<n){
if(n%k==0){
cout<<"false";
return false;
}
k++;
StrangeSeq(n);
}
else
{
cout<<"true";
return true;
}
}
int main(){
int n;
cin>>n;
StrangeSeq(n);
cin.get();
cin.get();
}