3. Напишите программу, реализующую заполнение случайными числами 20 элементов массива D и вывод их на экран. Элементы массива – это целые числа из промежутка [0;35].
4. Дан одномерный массив В, размерностью 10. Элементы массива – это целые числа из промежутка [0;100]. Напишите программу, вычисляющую сумму элементов массива, которые больше 8 и кратны 12.
Язык программирования Паскаль
В памяти - Оперативной и постоянной (HDD)
3.Выберите из списка операционные системы:
1)WINDOWS
3)LINUX
5)MS-DOS
4.Выберите изсписка название файла:
1)образ.нет;
3)математика.com;
5.Отметьте устройства,предназначенные для вывода информации:
устро́йства вы́вода — периферийные устройства, преобразующие результаты обработки цифровых машинных кодов в форму, удобную для восприятия человеком.
1)принтер
3)монитор
5)графопостроитель
10)акустические колонки
6.Что входит в состав системного блока?
материнская плата
Процессор,
оперативная память,
видеоплата,
жесткий диск,
блок питания
var
a,b,sum : integer;
begin
Readln(a, b);
if (a mod b = 0) then
begin
while a > 0 do
begin
sum:= sum + (a mod 10);
a:= a div 10;
end;
if sum > b then
begin
Writeln('Верно');
halt;
end;
end;
Writeln('Неверно');
end.
Пример:
1234 2
Верно
2)
var
i: integer;
begin
For i:= 100 to 999 do
if (i*i)mod 1000 = i then Write(i, ' ');
end.
Результат:
376 625
3)
var
i,n : integer;
function Simple(n: Longint): boolean;
var
i: Longint;
begin
for i := 2 to Round(Sqrt(n)) do
if n mod i = 0 then
break;
Simple := n mod i <> 0;
end;
begin
Read(n);
For i:= 1 to Round(Sqrt(n)) do
if n mod i = 0 then
if (Simple(i))and(Simple(n div i)) then
begin
Writeln('YES');
halt;
end;
Writeln('NO');
end.
Пример:
33
YES