В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Неко6тян
Неко6тян
20.10.2021 12:12 •  Информатика

3: Напишите программу на языке Python. В программе случайным образом вводятся 20 положительных и отрицательных чисел в диапазоне от -10 до 10. a) вычислить произведение всех ненулевых чисел
b) найти количество отрицательных чисел
c) найти количество положительных чисел
d) определить каких чисел больше положительных или отрицательных

Вывести ответ в следующем формате:
Произведение чисел =
Количество положительных чисел =
Количество отрицательных чисел =
Больше чисел на

Показать ответ
Ответ:
Танек47896
Танек47896
04.10.2021 01:10

from random import randint

random_numbers = [randint(-10, 10) for x in range(20)]

print(random_numbers)  # show all random numbers list

positive_numbers = [n for n in random_numbers if n > 0]

negative_numbers = [n for n in random_numbers if n < 0]

print("Произведение чисел = {}".format(sum(positive_numbers)))

print("Количество положительных чисел = {}".format(len(positive_numbers)))

print("Количество отрицательных чисел = {}".format(len(negative_numbers)))

print("Больше {} чисел на {}".format(

   'положительных' if len(positive_numbers) > len(negative_numbers) else 'отрицательных',

   abs(len(positive_numbers) - len(negative_numbers

0,0(0 оценок)
Ответ:
katia6173
katia6173
04.10.2021 01:10

from random import randint

mass = [randint(-10, 10) for s in range(20)]

print(mass)

mult = 1

posit = negat = 0

for i in mass:

   if i:

       mult *= i

   if i < 0:

       negat += 1

   if i > 0:

       posit += 1

print(f'Произведение чисел = {mult}\nКоличество положительных чисел = {posit}\nКоличество отрицательных чисел = {negat}')

print(f'Больше {"отрицательных" if posit - negat < 0 else "положительных"} чисел на {abs(posit - negat)}')

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота