В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
fatima52
fatima52
29.07.2020 21:33 •  Информатика

3. написать программу на языке java, которая по заданному номеру единицы измерения (1 – килограмм, 2 – миллиграмм, 3 – грамм, 4 – тонна, 5 – центнер) и массы m выдавала бы соответствующее значение массы в килограммах.

Показать ответ
Ответ:
алинагаврова
алинагаврова
05.10.2020 02:04
Import java.util.*;

public class zadacha
{

public static void main(String[]args)

{

cout("Введите номер ед.изм: ");

@SuppressWarnings("resource") Scanner cin = new Scanner (System.in);
double v=cin.nextInt();

cout("Введите массу в указанной ед.изм: ");
double m=cin.nextDouble();

if (v==1) {
  print(m);
 }

else if (v==2) {
  print(m/st(6));
 }

else if (v==3) {
  print(m/st(3));
  }

else if (v==4) {
  print(m*st(3));
 }

else if (v==5) {
  print(m*st(2));
}

}

public static void cout (String text)
{
 System.out.print(text);
}
public static void print(double printer)
{
 System.out.print(printer);
}

public static int st(int t)
{
t=(int) Math.pow(10, t); return t;
}

}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота