В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
agrdoon
agrdoon
18.07.2020 12:08 •  Информатика

3.На вход программе подается натуральное число. Найдите произведение ненулевых цифр числа.Питон

Показать ответ
Ответ:
Судзуми777
Судзуми777
13.10.2020 13:26

from functools import reduce

print(reduce(lambda x,y: x*y, [int(x) for x in input() if x != '0']))

Или менее красиво, но зато так как потом попросили:

a: int = 1

for x in input():

 a *= int(x) if x != '0' else 1

print(a)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота