В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Weronika2017
Weronika2017
01.07.2020 20:57 •  Информатика

25 ! (составьте программу паскаль) уличный продавец газет получает а рублей с продажи каждой из первых 50 газет. с продажи каждой из остальных газет он получает на 20% больше. вычислите дневной заработок продавца, k газет в день.

Показать ответ
Ответ:
elina162006
elina162006
21.04.2020 08:25
Var
    k: integer;
    a, s: real;

begin
    write('Начальная стоимость: ');
    readln(a);
    write('Число проданных газет:  ');
    readln(k);
    
    if k <= 50 then s := k * a
    else
    begin
        s := 50 * a;
        s := s + (k - 50) * a * 1.2;
    end;
    writeln('Выручка составила  ', s, ' руб.');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота