В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
тигр187
тигр187
04.05.2022 04:21 •  Информатика

2 задания напишите на каком языке программировали: 1.B. Укладка плитки

Ограничение времени 1 секунда

Ограничение памяти 64.0 Мб

Ввод стандартный ввод или input.txt

Вывод стандартный вывод или output.txt

Мэр нашего города хочет уложить максимум плит размером 2 × 1 клеток без деления их пополам на площади размером K × N клеток. Требуется уложить максимум плит при условии, что:

Можно поворачивать плиты

Плиты не пересекаются

Все плиты лежат внутри площади, касание краёв допускается.

Найдите максимум плит, которые можно уложить при данных условиях.

Формат ввода

В единственной строке записано два целых числа K и N — размеры площади в клетках (1 ≤ K ≤ N ≤ 16)

Формат вывода

Выведите одно число — максимальное количество плит, которые можно уложить

Пример 1

Ввод Вывод

2 4

4

Пример 2

Ввод Вывод

3 3

4

2. задача вторая

Ограничение времени 1 секунда

Ограничение памяти 64.0 Мб

Ввод стандартный ввод или input.txt

Вывод стандартный вывод или output.txt

В Чувашской республике проходит командная олимпиада по программированию. Трое друзей - Вася, Валя и Володя решили поучаствовать в ней в составе одной команды. Они договорились, что будут делать только те задачи, в которых уверены хотя бы двое из них.

На олимпиаде было

n

n задач. Для каждой из задачи известна уверенность каждого из друзей в решении. Найдите количество задач, которые будут решать ребята.

Формат ввода

В первой строк записано целое число

n

(

1



n



1000

)

n(1≤n≤1000) - количество задач на олимпиаде.

В следующих

n

n строках написано по три числа, каждое из которых равно 0 или 1. Если

i

i-e число в строке равно 1, то

i

i-ый друг уверен в её решении, иначе не уверен. Числа разделены пробелами.

Формат вывода

Выведите целое число — количество задач, которые друзья будут решать на олимпиаде.

Пример 1

Ввод Вывод

3

1 1 1

1 0 0

1 0 1

2

Пример 2

Ввод Вывод

2

0 1 1

0 0 1

1

Примечания

В первом примере трое человек уверены в решении первой задачи, в третьей только двое, а во второй только один из друзей.

Во втором примере друзья уверены только во первой задаче.

Показать ответ
Ответ:
Sania24sania
Sania24sania
28.05.2021 21:58

Напомню, что логическое «И» истинно только тогда, когда истинны оба высказывания. Таким образом, в искомом имени первая буква должна быть согласной, а последняя − гласной

1)Анна не подходит, потому что первая буква у нее гласная

2)Роман не подходит,поскольку последняя буква согласная

3)Олег не подходит, так как первая буква гласная, а последняя согласная

4)Татьяна подходит, потому что первая буква у неё не гласная и последняя буква у нее не согласная

Под такие условия подходит только имя Татьяна

ответ: Татьяна

0,0(0 оценок)
Ответ:
maximkolosov66
maximkolosov66
25.12.2021 09:23

Программа:

def F(n):

   if n <= 18:

       return n + 3

   elif n > 18 and n % 3 == 0:

       return (n // 3) * F(n // 3) + n - 12

   else:

       return F(n - 1) + n * n + 5

k = 0

for i in range(1, 801):

   m = 0  # Обнуляем переменную проверки длины четных цифр в числе

   for j in range(len(str(F(i:  # Пробежимся по длине числа (От 0 до len('число'))

       if int(str(F(i))[j]) % 2 == 0:  # Проверяем каждую цифру числа на чётность

           m += 1  

   if m == len(str(F(i))):  # Если значение переменной совпадает с длиной числа, то..

       k += 1

print(k)

ответ: 16

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота