В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
MissEmilyaBlood
MissEmilyaBlood
08.04.2021 20:34 •  Информатика

2. составьте программу для нахождения количества литров l, которое содержится в x галлонах (1 галлон = 4,54609 литра). исходное количество галлонов задается с клавиатуры. 3. напишите программу вычисления общего члена bn и суммы sn первых n членов прогрессии. первый член прогрессии b1, знаменатель прогрессии q и число членов с клавиатуры.

Показать ответ
Ответ:
princessss88
princessss88
05.10.2020 09:18
//PascalABC.NET 3.2 сборка 1318

Const
  gal=4,54609;

  Var
  x:real;
begin
readln(x);
writeln(x*gal);
end.

//2

Var
  b1,q:real;
  n:integer;
begin
readln(b1,q,n);
if (b1=0) or (q=0) then
  begin
    writeln('b1=0 or q=0');
    exit;
  end
else
if q=1 then
   begin
    writeln('Sum=',b1*n);
    writeln('Bn=',b1);
  end
 else
 begin
  Writeln('Sum=',b1*(1-power(q,n))/(1-q));
  Writeln('Bn=',b1*power(q,n-1));
 end;
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота