В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Поняха74
Поняха74
19.05.2021 11:10 •  Информатика

2. составить программу для нахождения цифр четырехзначного числа. ниже представлен пример диалога. данные, вводимые пользователем, выделены жирным шрифтом. введите четырехзначное число 3281 число тысяч равно 3 число сотен равно 2 число десятков равно 8 число единиц равно 1

Показать ответ
Ответ:
edkot
edkot
26.05.2020 19:27

Program pr;
uses crt;
Var a, x1, x2, x3, x4:integer;
Begin
Writeln('введите 4-х значное число');
readln(a);
x1:=a div 1000;
x2:=(a mod 1000) div 100;
x3:=(a mod 100) div 10;
x4:=a mod 10;
Writeln(x1);
Writeln(x2);
Writeln(x3);
Writeln(x4);
readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота