В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
katerinam2001
katerinam2001
01.12.2022 22:29 •  Информатика

2. Напишите программу, которая при наборе с клавиатуры названия страны выводит на экран название столицы
данной страны и численность населения, проживающего
В ней.

(как можно понятнее)


2. Напишите программу, которая при наборе с клавиатуры названия страны выводит на экран название сто

Показать ответ
Ответ:
Артем1526
Артем1526
03.03.2021 11:35

C#

string a;

           ConsoleKeyInfo keyInfo;

           do

           {

               Console.WriteLine("Введите одну из перечисленных стран:\n*Венгрия\n*Италия\n*Греция\n*Турция\n*Египет\n*Непал\n*Бельгия\n");

               a = Convert.ToString(Console.ReadLine());

               switch (a)

               {

                   case ("Венгрия"):

                       Console.WriteLine("Столица: Будапешт\nНаселение: 9,7 млн чел.\n");

                       break;

                   case ("Италия"):

                       Console.WriteLine("Столица: Рим\nНаселение: 60 млн чел.\n");

                       break;

                   case ("Греция"):

                       Console.WriteLine("Столица: Афины\nНаселение: 10 млн чел.\n");

                       break;

                   case ("Турция"):

                       Console.WriteLine("Столица: Анкара\nНаселение: 55 млн чел.\n");

                       break;

                   case ("Египет"):

                       Console.WriteLine("Столица: Каир\nНаселение: 53 млн чел.\n");

                       break;

                   case ("Непал"):

                       Console.WriteLine("Столица: Катманду\nНаселение: 29 млн чел.\n");

                       break;

                   case ("Бельгия"):

                       Console.WriteLine("Столица: Брюссель\nНаселение: 11 млн чел.\n");

                       break;                    

                   default:

                       Console.WriteLine("Неверно введены данные\n");

                       break;

               }    

               

               Console.WriteLine("Если хотите повторить программу нажмите F");

               Console.WriteLine("Если хотите завершить программу нажмите любую другую кнопку\n");

               keyInfo = Console.ReadKey(true);

           }

           while (keyInfo.Key == ConsoleKey.F);


2. Напишите программу, которая при наборе с клавиатуры названия страны выводит на экран название сто
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота