В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lizokf8
lizokf8
10.07.2021 16:43 •  Информатика

2. написать программу, которая вводит массив из n целых чисел и выводит на экран элементы, кратные числу k. протестировать программу на следующих исходных данных: а) k=3 массив: 2 6 -9 4 5 12 -15 б) k=4 массив: 9 0 8 124 -16 11 19 на паскале

Показать ответ
Ответ:
arty181118
arty181118
15.07.2020 15:29
Var 
a:array [1..100000] of integer;
i,n,k:integer;
begin
writeln('Введите n и k');
readln(n,k);
for i:=1 to n do
begin
writeln('Введите элемент №',i);
readln(a[i]);
end;
writeln('Весь массив:');
for i:=1 to n do
write(a[i],' ');
writeln();
writeln('Числа кратные ',k,':');
for i:=1 to n do
if a[i] mod k = 0 then
write(a[i],' ');
end.
ТЕСТ №1:
Весь массив:
2 6 -9 4 5 12 15 
Числа кратные 3:
6 -9 12 15 

ТЕСТ №2:
Весь массив:
9 0 8 124 -16 11 19 
Числа кратные 4:
0 8 124 -16 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота