В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
вика3850
вика3850
12.10.2020 09:05 •  Информатика

2. Написать программу для исполнителя «Стрелочка» рисующую змейку на всю ширину поля. Начальное состояние исполнителя: т.А(0, 4), направление – вниз. Размер зубца – один шаг.


2. Написать программу для исполнителя «Стрелочка» рисующую змейку на всю ширину поля. Начальное сост

Показать ответ
Ответ:
deniskiselev1
deniskiselev1
09.01.2021 06:56

Найдём значения в ячейках B2, C2, D2.

B2 = B1 + C1 = 1 + 8 = 9C2 = D1 * 3 = 3 * 3 = 9D2 = A1 / 3 = 6 / 3 = 2

Осталось найти A2.

Давайте посмотрим на рисунок. На нём видно, что диаграмма состоит из двух частей: одна очень маленькая, две одинаковые и самая большая.

Давайте посмотрим на имеющиеся данные. Эти две одинаковые части могут принимать значения ячеек B2 и C2, то есть равняться 9. Маленькая часть - 2.

Узнаем, чему равен каждый вариант ответа.

A1 - D1 = 6 - 3 = 3. Маловато для такой большой части.(C1 + B1) / 3 = (8 + 1)  / 3 = 3. Маловато.A1 + C1 + 2 * B1 = 6 + 8 + 2 * 1 = 16. О, нормально.(C1 - A1) / 2 = (8 - 6) / 2 = 1. Ну очень мало, даже меньше самой маленькой части.

Получается, что третий вариант является единственным подходящим.

ответ: A1 + C1 + 2 * B1 (16).

- - - -

Кстати, вот эти две одинаковые части, похоже, являются половиной. Значит, найдём целое:

(9 + 9) * 2 = 18 * 2 = 36

Вычтем известное и получим неизвестную часть:

36 - 9 - 9 - 2 = 16

¯\_(ツ)_/¯

0,0(0 оценок)
Ответ:
Василий300
Василий300
20.10.2022 07:44

#include <iostream>

#include <ctime>

using namespace std;

int main()

{

       int M = 5;

       int N = 7;

       srand(time(NULL));      // новая точка отсчета рнд

       int B[M][N];            // массив

       int cnt;                // число отрицательных

       // заполняем массив случайными:

       for (int i=0; i<M; i++)

           for (int j=0; j<N; j++)

               B[i][j] = rand() %21 - 10;

       //выводим массив

       for(int i = 0; i < M; ++i) {

           cout<<"|";

           for(int j = 0; j < N; ++j){

           cout <<" "<< B[i][j] << " ";

           cout<<"|";

       }

       cout << endl;

   }

       // считаем отрицательные:

       for (int i=0; i<N; i++)

       {

           cnt = 0;        // перед каждым новым столбцом сбрасываем счетчик отрицательных

           for (int j=0; j<M; j++)

               if (B[i][j] < 0) cnt++;

           cout << "column:"<<i<< " "<< "kol-vo:"<<cnt<< endl;

       }

}

Объяснение:

вроде работает если что пиши

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота