В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Frolinng
Frolinng
14.07.2020 07:46 •  Информатика

1составить программу на языке паскаль. написать программу, заносящую в файл массив из 7 вещественных чисел, введенных с клавиатуры, а потом считывающую этот массив и выводящую на экран количество отрицательных элементов. если таких нет, то выдать об этом сообщение. 2. составить программу на языке паскаль. описать функцию нахождения максимума для двух величин. ввести с клавиатуры a,b,c,d. для каждой пары величин найти максимальную, а потом напечатать большее из максимальных величин.

Показать ответ
Ответ:
nastya3454578335678
nastya3454578335678
20.06.2020 09:32
1)
var f:text; a:array[1..7] of real; i,k,c,x:integer; s:string;
begin
 for i:=1 to 7 do
   begin
    readln(x);
    a[i]:=x;
   end;
 assign(f,'file.txt');
 rewrite(f);
 for i:=1 to 7 do
   begin
    str(a[i],s);
    writeln(f,s);
   end;
 close(f);
 reset(f);
 k:=0;
 while not eof(f) do
   begin
    readln(f,s);
    val(s,x,c);
    if x<0 then k:=k+1;
   end;
 close(f);
 if k<>0 then writeln('В массиве ',k,' отрицательных элемента(ов)');
  else writeln('В массиве нет отрицательных элементов');
 erase(f);
end.

2)
Var a,b,c,d:integer;

Function max(a,b:integer):integer;
begin
 if a>b then max:=a
  else max:=b;
end;

Begin
 readln(a,b,c,d);
 a:=(max(a,b)); 
 b:=(max(c,d));
 writeln('max=',max(a,b));
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота