§ 18. Практическая работа «Линейные программы»
1. Требуется написать программу, которая складывает два числа и выводит на экран их сумму.
Определите входные данные и результат этого алгоритма.
К какому типу относятся входные данные:
Сколько входных значений у алгоритма?
К какому типу относятся результаты:
Сколько результатов у алгоритма?
Обозначьте именами входные данные и результаты и напишите их на стрелках:
Запишите формулу, которая связывает исходные данные и результат:
Место для ввода текста.
2. Требуется написать программу, которая выводит скорость и времядвижения автомобиля и выводит на экран расстояние, которое он проехал.Определите входные данные и результат этого алгоритма.
К какому типу относятся входные данные:
Сколько входных значений у алгоритма?
К какому типу относятся результаты:
Сколько результатов у алгоритма?
Обозначьте именами входные данные и результаты и напишите их на стрелках:
Запишите формулу, которая связывает исходные данные и результат:
Место для ввода текста.
3. В языке Python целые переменные относятся к типу (классу)int. Выясните, откуда произошло сокращениеint в языках программирования:
int – это сокращение от английского слова , которое переводится как .
4. Выделите красным фономнедопустимые имена переменных:
1 Vasya СУ-27 @mail_ru
m11 Петя СУ_27 lenta.ru
1m Митин брат _27 "Pesbarbos"
m 1 Quovadis СУ(27) <Ладья>
5. Что появится на экране после выполнения программы:
c = 5
print( с )
print( 'c' )
ответ:
Чем отличаются два оператора вывода в программе?
Место для ввода текста.
6. Что выведет на экран программма
a= 1
print( a )
a= 5
print( a ) ответ:
Заполните пропуски: «Если переменной присваивается новое значение, то предыдущее значение .»
Выберите правильный вариант: «Переменнаяв любой момент может иметь ».
7. Чему будут равны значения переменных a и b после выполнения программмы, если вначале они имели значения a = 4 и b = 7? Выполните ручную прокрутку программы.
a b
4 7
a= a + 1
b= b + 1
a= a + b
b= b + a
a= a + 1
ответ: a = b =
8. Что выведет эта программа приa = 4, b = 5иc = 9?
print( 'a','+b',=,c )
Место для ввода текста.
9. Исправьте ошибки в операторе вывода,
print( 'c','-b',=, a )
чтобы при a = 4, b = 5 и c = 9 программа вывела 9–5=4:
Место для ввода текста.
10. Определите порядок действий компьютера при вычислении выражения (впишите номер выполняемого действия над знаком операции):
Const N = 499; M = 1;
Var A: Array [1..N, 1..N] of Boolean;
i, j, x, y, t: Integer;
b: Boolean;
Begin
Randomize;
While i < M Do
Begin
x := Random(N) + 1;
y := Random(N) + 1;
If A[x, y] = False Then
Begin
A[x, y] := True;
i := i + 1;
End;
End;
While b = False Do
Begin
b := True;
For i := 1 To N Do
For j := 1 To N Do
Begin
If A[i, j] = True Then
Begin
If (i + 1) <= N Then
A[i + 1, j] := True;
If (i - 1) > 0 Then
A[i - 1, j] := True;
If(j + 1) <= N Then
A[i, j + 1] := True;
If (j -1) > 0 Then
A[i, j - 1] := True;
End;
End;
For i := 1 To N Do
For j := 1 To N Do
If A[i, j] = False Then
b := False;
t := t + 1;
End;
WriteLn(t);
ReadLn;
End.
Чтобы закодировать 2 возможных варианта, достаточно 1 бита.
Если нужно закодировать 3 варианта, то нужно будет уже 2 бита.
При чем 2мя битами можно закодировать 3 варианта и даже 4.
Количество исходов, или символов которые можно закодировать определяется по формуле: 2 в степени х = количество исходов.
где Х - количество Бит.
Так 2^5= 32 --- значит 5 битами можно закодировать 32 символа и менее.
2^6=64 --- 6ю битами можно закодировать 64 символа и менее.
Значит от вет будет 6 бит