Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
чирик15
11.12.2020 19:09 •
Информатика
18. написать программу на паскале,дана точка на плоскости с координатами х, у составить программу которая выведет одно из сообщение да нет на границе
Показать ответ
Ответ:
km73283
01.10.2020 11:10
int R = 15;
Console.Write("x=");
float x = float.Parse(Console.ReadLine());
Console.Write("y=");
float y = float.Parse(Console.ReadLine());
if (Math.Sqrt(Math.Pow(x,2) + Math.Pow(y,2)) < Math.Pow(R,2)) Console.WriteLine("внутри");
else if (Math.Sqrt(Math.Pow(x,2) + Math.Pow(y,2)) > Math.Pow(R,2)) Console.WriteLine("вне");
else Console.WriteLine("на границе");
0,0
(0 оценок)
Популярные вопросы: Информатика
motoquence
30.01.2023 00:52
)) программа запрашивает 2 целых числа после чего выводит на экран их сумму, произведение и разность квадратов...
YUSUFOV
10.04.2021 17:48
Информатика. билеты ...
Gay1122
10.05.2020 10:51
9. Укажите верное написание цвета в программе:...
Koroleva12112002
02.12.2021 07:44
Почему Есенин называет первый сборник своих стихов ((Радуница...
кпаприрр
20.08.2021 20:25
. Используя знание исторических фактов, объясните, почему это событие (процесс) имело большое значение в истории нашей страны и/или истории зарубежных стран. тема: правление...
yanaela2006
28.01.2020 16:59
На дворе какая часть речи...
принцеска005
03.01.2021 07:17
Твори які називаються концертами уперше з явились в: Іспания Франція Італія Украіна...
2йошник
27.04.2021 06:25
Почему можно говорить не только о природных, но и о природно-хозяйственных зонах?...
Sveta1100
16.08.2022 21:59
В широком смысле - это, прежде всего, всё то, что создано человеком. А в узком смысле - это традиции народа, поэзия и литература, фольклор, кухня и многое другое. Что это...
dianochkashiba
16.08.2022 21:59
РАЗОБРАТЬ ПО ЧЛЕНАМ ПРЕДЛОЖЕНИЯ Всё было полно,тенисто и густо,и молодые ели,рассыпанные по лесу,не нарушали общей красоты....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Console.Write("x=");
float x = float.Parse(Console.ReadLine());
Console.Write("y=");
float y = float.Parse(Console.ReadLine());
if (Math.Sqrt(Math.Pow(x,2) + Math.Pow(y,2)) < Math.Pow(R,2)) Console.WriteLine("внутри");
else if (Math.Sqrt(Math.Pow(x,2) + Math.Pow(y,2)) > Math.Pow(R,2)) Console.WriteLine("вне");
else Console.WriteLine("на границе");