100 ! написать программу языком с++
.
составить программу для вычисления заданного выражения с использованием функции пользователя. числовые данные задать самостоятельно.
первая колонка- выражение для вычислений.
вторая - выражение для вычислений с процедуры.
буду за ) выберу лучший ответ! !
#include <iostream>
using namespace std;
double P(double x, double y)
{
double a = 2 * x + y;
double b = x * y * y;
if(a > b)
return a;
else
return b;
}
int main()
{
cout << "Задайте значения А и В\n";
double A, B;
cin >> A >> B;
double Z = P(0.12 * A * A - 2 * A * B, A * A * B) -
2 * P(0.13 * A, 2 * A - B) +
0.48 * P(1.7 * A, 1.26 * B);
cout << "Z = " << Z << endl;
return 0;
}