В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

10 . подалуйста. умоляю.составить программу для машины тьюринга котрая увеличивает троичное число на 1. каретка находится справа от числа
​​

Показать ответ
Ответ:
Мика7477u
Мика7477u
20.03.2021 11:29

1

Задание 5 № 10383

У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 1;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Альфа увеличивает число на экране на 1, а выполняя вторую, умножает это число на b. Программа для исполнителя Альфа — это последовательность номеров команд. Известно, что программа 11211 переводит число 6 в число 82. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10384

У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 1;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Альфа увеличивает число на экране на 1, а выполняя вторую, умножает это число на b. Программа для исполнителя Альфа — это последовательность номеров команд. Известно, что программа 11211 переводит число 3 в число 62. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10385

У исполнителя Бета две команды, которым присвоены номера:

1. прибавь 2;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Бета увеличивает число на экране на 2, а выполняя вторую, умножает это число на b. Программа для исполнителя Бета — это последовательность номеров команд. Известно, что программа 12111 переводит число 7 в число 51. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10386

У исполнителя Бета две команды, которым присвоены номера:

1. прибавь 2;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Бета увеличивает число на экране на 2, а выполняя вторую, умножает это число на b. Программа для исполнителя Бета — это последовательность номеров команд. Известно, что программа 11121 переводит число 4 в число 72. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10387

У исполнителя Гамма две команды, которым присвоены номера:

1. прибавь 3;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Гамма увеличивает число на экране на 3, а выполняя вторую, умножает это число на b. Программа для исполнителя Гамма — это последовательность номеров команд. Известно, что программа 11211 переводит число 1 в число 97. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10388

У исполнителя Гамма две команды, которым присвоены номера:

1. прибавь 3;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Гамма увеличивает число на экране на 3, а выполняя вторую, умножает это число на b. Программа для исполнителя Гамма — это последовательность номеров команд. Известно, что программа 11121 переводит число 3 в число 75. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10389

У исполнителя Омега две команды, которым присвоены номера:

1. прибавь 4;

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Омега увеличивает число на экране на 4, а выполняя вторую, умножает это число на b. Программа для исполнителя Омега — это последовательность номеров команд. Известно, что программа 12111 переводит число 9 в число 77. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10390

У исполнителя Сигма две команды, которым присвоены номера:

1. прибавь 1;

2. раздели на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Сигма увеличивает число на экране на 1, а выполняя вторую, делит это число на b. Программа для исполнителя Сигма — это последовательность номеров команд. Известно, что программа 12111 переводит число 63 в число 11. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10391

У исполнителя Сигма две команды, которым присвоены номера:

1. прибавь 1;

2. раздели на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Сигма увеличивает число на экране на 1, а выполняя вторую, делит это число на b. Программа для исполнителя Сигма — это последовательность номеров команд. Известно, что программа 12111 переводит число 50 в число 20. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Задание 5 № 10392

У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 2;

2. раздели на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Альфа увеличивает число на экране на 2, а выполняя вторую, делит это число на b. Программа для исполнителя Альфа — это последовательность номеров команд. Известно, что программа 12111 переводит число 47 в число 13. Определите значение b.

Решение · Поделиться · Сообщить об ошибке Объяснение:

0,0(0 оценок)
Ответ:
asyamilos
asyamilos
09.09.2022 22:52

#include <iostream>

#include <clocale>

using namespace std;

int main()

{

   setlocale(LC_ALL,"Russian");

   int x, i, j, s;

   cout << "Введите x: ";

   cin >> x;

   for (int i = 2; i <= x; i++)

   {

       s = 0;

       for (int j = 1; j <= i / 2; j++)

       {

           if (i % j == 0)

           {

               s += j;

           }

       }

       if (s == i)

       {

           cout << i << " ";

       }

   }

}

Объяснение:

#include <iostream>  // Библиотека ввода-вывода

#include <clocale>  // Библиотека локализации (возможно, будет работать и без нее)

using namespace std;  // Пространство имён

int main()

{

   setlocale(LC_ALL,"Russian");  // Локализация в консоли (возможно, будет работать и без нее)

   int x, i, j, s;  // Объявление переменных

   cout << "Введите x: ";  // Выводим текст

   cin >> x;  // Вводим x с клавиатуры

   for (int i = 2; i <= x; i++)  // Выполняем до того момента, пока i <= x

   {

       s = 0;

       for (int j = 1; j <= i / 2; j++)  // Выполняем до того момента, пока j <= i ÷ 2 (без остатка)

       {

           if (i % j == 0)  // Если остаток от i ÷ j = 0

           {

               s += j;  // К s прибавляется j

           }

       }

       if (s == i)  // Если s = i

       {

           cout << i << " ";  // Выводим i с пробелом

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота