В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
mastermin
mastermin
02.08.2021 09:55 •  Информатика

10 . pascal abc. даны два массива. написать программу вычисляющую среднее арифметическое элементов каждого массива и сравнить эти значения.

Показать ответ
Ответ:
masha91672
masha91672
09.10.2020 12:46

попробуй  

programm dima;

var

m1:array[1..50]of integer;

m2:array[1..50]of integer;

n1,n2,i:integer;

arifm1,arifm2:real;

 

 

begin

  writeln('Vvedite rozmeri masivov');

   readln(n1,n2);

   randomize;

   writeln('Masiv 1:');

   for i :=1 to n1 do

   begin

    m1[i]:=random(50);

    write(m1[i],' ');

    end;

    writeln;

    writeln('Masiv 2:');

   for i:=1 to n2 do

     begin

    m2[i]:=random(60);

    write(m2[i],' ');

    end;

    for i :=1 to n1 do

     arifm1:= arifm1+m1[i];

     arifm1:=arifm1/n1;

 

      for i :=1 to n2 do

     arifm2:= arifm2+m2[i];

      arifm2:=arifm2/n2;

      writeln;

      if arifm1=arifm2 then

        writeln('seredne arifmetichne rovnie')

        else

         if arifm1>arifm2 then

           writeln('seredne arifmetiche 1 masiva bilche')

            else

            writeln('seredne arifmetiche 2 masiva bilche');

  end.

   

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота