В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

10. напишите программу: "склавиатуры вводится строка из двух слов. вывести н экран: a) первую и последнюю буквы второго слова; б) количество букв второго слова; в) количество глассных (a) в строке.все это должно быть в одной программе

Показать ответ
Ответ:
Vikysiax99
Vikysiax99
07.10.2020 11:36
Var s: string;
    n,k: integer;
begin
   write('строка: ');  readln(s);
   n:=pos(' ',s);
   if n>0 then 
   begin
     writeln('первая буква второго слова: ',s[n+1]);
     writeln('последняя буква:  ',s[length(s)]);
     writeln('количество букв:  ',length(s)-n);
     k:=0; 
     for n:=1 to length(s) do 
     if s[n]='a' then k:=k+1;
     if k>0 then writeln('количество букв a: ',k)
     else writeln('в строке нет буквы a');
   end
   else writeln('в строке одно слово');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота