В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
DARKFEST1
DARKFEST1
05.02.2022 02:31 •  Информатика

10.Напишите программу, которая находит произведение двух наименьших чисел из последовательности натуральных чисел. Программа получает на
вход натуральные числа, количество введённых чисел неизвестно (но не
менее двух), последовательность чисел заканчивается числом 0 (0 — признак
окончания ввода, не входит в последовательность). Количество чисел не
превышает 1000. Введённые числа не превышают 10 000.
Программа должна вывести одно число: произведение двух чисел, значения
которых в данной последовательности наименьшие.
Пример работы программы:
Входные данные
10
7
8
9
0
Выходные данные
56
РЕШИТЕ УМОЛЯЮ А ТО МНЕ ППЦ ОТ РОДИТЕЛЕЙ РЕШИТЕ

Показать ответ
Ответ:
ratmir10
ratmir10
04.02.2021 18:30

n1 = 9*99

n2 = 9*99

count = 0

while 1:

   a = int(input())

   

   if count < 2 and a == 0:

           print("минимум два числа")

           count -= 1

   elif  count == 1000:

       print("чисел не может быть больше 1000")

       break

   elif a > 10000:

       print("Число не может быть больше 10.000")

       count -= 1

   elif a == 0:

       break

   elif a < n1:

       n1 = a

   elif a < n2:

       n2 = a

   count += 1

print(n1*n2)


10.Напишите программу, которая находит произведение двух наименьших чисел из последовательности нату
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота