В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ghbdtnzujdyjfns
ghbdtnzujdyjfns
18.12.2021 13:17 •  Информатика

1 задание
Преобразовать одномерный массив вещественных чисел, присвоив каждому элементу квадрат его значения. (в Java)
2 задание
Даны действительные числа s,t. Составить программу вычисления выражения f(t, -2s, 1.17) + f(2.2, t, s-t), где f(a,b,c) = (2a – b – sin(c)) / (5 + |c|). (в Java)

Показать ответ
Ответ:
lenapanfilova0
lenapanfilova0
01.05.2022 23:39

Я не буду расписывать всё по разным классам, поэтому человек в одной программе будет только один!!

package com.project;

import java.util.Scanner;

public class Name {

public static int all_marks = 0;

public static int reckoning(int mark) {

return Name.all_marks += mark;

}

public static void diplom(String name) {

if (Name.all_marks > 80) {

System.out.println("Диплом") ;

System.out.println("Награждается: " + name);

System.out.println("За набранное количество в размере: " + Name.all_marks);

}

else if ((Name.all_marks > 50) && (Name.all_marks <= 80)) {

System.out.println("Сертификат") ;

System.out.println("Награждается: " + name);

System.out.println("За набранное количество в размере: " + Name.all_marks);

}

else

System.out.println("Сертификат участника");

}

public static void main(String[] args) {

Scanner in = new Scanner(System.in);

String name;

int num_lessons, marks;

System.out.print("Enter a student's name: ");

name = in.nextLine();

System.out.print("Enter the number of items that are surrendered by a student " + name + ": ");

num_lessons = in.nextInt();

for (int i=1; i<=num_lessons; i++) {

System.out.print("Enter the number of points a student has scored for " + i + " lesson: ");

marks = in.nextInt();

reckoning(marks);

}

diplom(name);

}

}

0,0(0 оценок)
Ответ:

ответ: См. снимки экрана (код в объяснении)

Объяснение:

Первая программа:

from random import randint

def geo_mean(arr):

   m = 1

   for x in arr:

       m *= x

   res = m ** (1 / len(arr))

   return res

def even_numb(arr):

   sum = 0

   for x in arr:

       if not x % 2:

           sum += x

   return sum

   res = m ** (1 / len(arr))

   return res

arr = []

for i in range(50):

   arr.append(randint(1, 10))  # Геренрирование случайных чисел

print(arr, '\n')

print("G =", geo_mean(arr))  # Среднее геометрическое

if even_numb(arr) < 240:  # Сумма четных чисел

   print("Сумма четных элементов равна", even_numb(arr))

Вторая программа:

def numb_words(s):

   s = s.split()

   l = len(s)

   if l >= 3:

       return True

def numb_letters(a):

   return len(a) - a.count(' ')

a = input("Введите фразу: ")

if (numb_words(a)):

   if numb_letters(a) < 10:

       print("Хорошо")

   else:

       print("Не хорошо")


1) Сгенерировать список из 50 случайных элементов, значения от 1 до 10 (через бибилотеку random), по
1) Сгенерировать список из 50 случайных элементов, значения от 1 до 10 (через бибилотеку random), по
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота