В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ангел709
ангел709
29.12.2022 00:59 •  Информатика

1 Задан целочисленный одномерный массив а состоящий из n элементов. Написать программу подсчета количества, суммы и произведения отрицательных элементов массива. 2 Перенести условие задачи 1 на использование двумерного массива а, размерности 3×3.

Показать ответ
Ответ:
lediyulia04
lediyulia04
14.12.2020 12:54

1.

#include <iostream>

#define N 10

int main()

{

using namespace std;

int count = 0, sum = 0, mult = 1;

int arr[N]{0, 7, 5, 2, -10, -3, 4, 6, 12, -1};

for (const auto i : arr)

{

 if (i < 0)

 {

  count++;

  sum += i;

  mult *= i;

 }

}

cout << "Count = " << count << "\nSum = " << sum

<< "\nMult = " << mult;

return 0;

}

2.

#include <iostream>

#define N 3

int main()

{

using namespace std;

int count = 0, sum = 0, mult = 1;

int arr[N][N]{0, 7, 5, 2, -10, -3, 4, 6, -1};

for (int i = 0; i < N; i++)

{

 for (int j = 0; j < N; j++)

 {

  if (arr[i][j] < 0)

  {

   count++;

   sum += arr[i][j];

   mult *= arr[i][j];

  }

 }

}

cout << "Count = " << count << "\nSum = " << sum

<< "\nMult = " << mult;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота