В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Mashirachan
Mashirachan
28.02.2021 18:13 •  Информатика

1. Вводится одномерный массив размерностью 40 для обработки данной программой. Что делает программа?
var a: array [1..40] of integer;
1, p, n: integer;
begin
for i:=1 to 40 do begin
a[i]:=10+random(90);
write(a[i]. '');
end;
writeln;
for n:=1 to 40 div 2 do
begin
p:=a[n]:
а[n]:=a[n+1]:
а[n+1]:=p;
end;
for i:=1 to 40 do
write(a[i]: ');
end
Данная программа осуществляет:
а) перестановку наибольшего и наименьшего
значений;
b) меняет местами значения элементов, стоящие на
чётных местах,
значениями элементов,
стоящими на нечетных местах;
с) меняет порядок следования значений элементов в
массиве на обратный порядок,
d) переставляет первый элемент в середину массива.
со

Показать ответ
Ответ:
ekaterimazimina
ekaterimazimina
03.09.2022 22:50
1. 2 Массивы объявляются тем же оператором, что и обычные переменные
2. Не корректный вопрос: индекс - это обращения к определенному элементу массива, а у самого массива индекса нет. В вариантах ответа ничего похожего на это нет.
3. 4 Массивы заполняются теми же операторами, что и обычные переменные
4. 1 Есть такой ввода в бейсике - конструкция READ DATA
5. 1 Выведется четвертый элемент массива, т.к. нумерация идет с нуля, и первый имеет номер 0, второй - 1, третий - 2, а четвертый - номер 3, который и запрашивается в выражении А(3)
0,0(0 оценок)
Ответ:
dvortrans
dvortrans
27.03.2020 07:17
//Блок-схемы в приложении
//Pascal ABC.NET v3.0 сборка 1111

//1
Var
 a,p,s:real;
begin
readln(a);
p:=a*4;
s:=a*a;
writeln('P=',p);
writeln('S=',s);
end.

//2
Var
 a,b:integer;
begin
 read(a,b);
 if a>b then writeln(b);
 if a=b then writeln('=');
 if a<b then writeln(a);
end.

{На этом и закончу всем, кто когда либо и чем либо поддерживал данный проект. Думаю, он ещё многим послужит в критический момент. И я говорю не только про "списать домашку". Счастливо оставаться, господин Alviko. Может, ещё увидимся.
Ваш, Глеб 'I3artle' Косырев}
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота