В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ULYAVALEREVNA
ULYAVALEREVNA
11.01.2022 10:53 •  Информатика

1 Ввести два целочисленныхмассива − по 10 элементов в каждом. Сформировать новый массив, на четных местах которого будут элементы с нечетными индексами из первого массива, а нанечетных – с четными индексами из второго. 2 В заданном целочисленном массиве R(9) определить индекс наибольшего из нечетных
по значению положительных элементов
3 Ввести массив, состоящий из 12 элементов действительного типа. Расположить
элементы в порядке убывания. Определить количество происшедших при этом
перестановок
Написать программу на с++

Показать ответ
Ответ:
girrrrl
girrrrl
27.08.2020 09:11

Объяснение:

h,w = int(input().split())

c,p = int(input().split())

s = []

roadm = []

parks = []

cp = []

for i in range(1, h+1):

 for j in range(1, w+1):

   s.append([i,j])

for k in s:

 if k[0]==1 or k[1]==1:

    roadm.append(s.pop(k))

for t in s:

 if t[0] == 2 or t[1] == 2:

   cp.append(s.pop(t))

for y in s:  

 if y[0] == (f[0]+1 for f in cp) and y[1] == (f[1]+1 for f in cp) and y[0] == (f[0]-1 for f in cp) and y[1] == (f[1]-1 for f in cp):

   parks.append(s.pop(y))

a = []

b = []

for o in s:

 a.append(o[0])

 b.append(o[1])

print(min(a))

print(min(b))

0,0(0 оценок)
Ответ:
valeriaky0707
valeriaky0707
14.08.2020 07:48

C# самый простой вариант. Не нравится - совершенствуйте

на форму label1, textBox1, textBox2, textBox3, button1, button2, button3, this.button4, this.button5, this.button6

в Form1.cs

using System;

using System.Collections.Generic;

using System.ComponentModel;

using System.Data;

using System.Drawing;

using System.Linq;

using System.Text;

using System.Windows.Forms;

namespace WindowsFormsApplication1

{

public partial class Form1 : Form

{

public Form1()

{

InitializeComponent();

}

double a, b, result;

private void button1_Click(object sender, EventArgs e)

{

a = Convert.ToDouble(textBox1.Text);

b = Convert.ToDouble(textBox2.Text);

label1.Text = "Сумма";

result = a + b;

textBox3.Text = Convert.ToString(result);

}

private void button2_Click(object sender, EventArgs e)

{

a = Convert.ToDouble(textBox1.Text);

b = Convert.ToDouble(textBox2.Text);

label1.Text = "Разность";

result = a - b;

textBox3.Text = Convert.ToString(result);

}

private void button3_Click(object sender, EventArgs e)

{

label1.Text = "Произведение";

textBox3.Text = Convert.ToString(Convert.ToDouble(textBox1.Text) * Convert.ToDouble(textBox2.Text));

}

private void button4_Click(object sender, EventArgs e)

{

a = Convert.ToDouble(textBox1.Text);

b = Convert.ToDouble(textBox2.Text);

label1.Text = "Частное";

result = a / b;

textBox3.Text = Convert.ToString(result);

}

private void button5_Click(object sender, EventArgs e)

{

textBox3.Text = Convert.ToString(Convert.ToDouble(textBox1.Text) * Convert.ToDouble(textBox1.Text));

}

private void button6_Click(object sender, EventArgs e)

{

textBox3.Text = Convert.ToString(Math.Sqrt(Convert.ToDouble(textBox1.Text)));

}

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота