В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
danyok132006
danyok132006
21.11.2021 22:08 •  Информатика

1. В массиве хранятся данные о ежедневной температуре в течение августа (случайные числа от 15 до 25). Составьте программу для нахождения среднемесечной температуры. 2. Массив содержит информацию об отметках по информатике 20 учащихся класса. Отметки вводятся с клавиатуры. Составьте программу, которая вычисляет средний по предмету и количество учащихся с отметками выше среднего

Показать ответ
Ответ:
Djdjdhjx
Djdjdhjx
20.10.2020 17:01

program xxx;

var i, m, p, n : integer;

t : array[1..31] of real;

begin

writeln('введите температуру ')

for i:=1 to 31 do

readln(t[i]);

m:=0; p:=0; n:=0;

for i:=1 to 31 do

begin

if t[i]<0 then m:=m+1;

if t[i]>0 then p:=p+1;

if t[i]=0 then n:=n+1

end;

writeln('Дней с отрицательной температурой было - ', m);

writeln('Дней с положительной температурой было - ', р);

writeln('Дней с нулевой температурой было - ', n);

readln

end.

Объяснение:

Прописка

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота