1. Укажите операторы, используемые для ввода данных в Паскале.
Да/нет
read
writeln
readln
write
begin
var
2. Расположите строки так, чтобы получилась программа Symma, рассчитывающая по двум введённым с клавиатуры числам их сумму. В ответе запишите правильную последовательность номеров.
1. program Symma;
2. Rezult:=А+В;
3. write ('Сумма равна ', Rezult)
4. var А, В, Rezult: integer ;
5. begin
6. read (A, B);
7. write ('Введите два числа: ');
8. end.
ответ:
помагите
216₈ = 142₁₀ = 8Е₁₆
D3₁₆ = 211₁₀ = 323₈
Объяснение:
Переведите число 216₈ по схеме А8 → А10 → А16
216₈ = 2 * 8² + 1 * 8¹ + 6 * 8⁰ = 2 * 64 + 1 * 8 + 6 * 1 = 128 + 8 + 6 = 142₁₀
216₈ = 142₁₀
142 / 16 = 8 + остаток 14 (Е)
8 / 16 = 0 + остаток 8
записываем остатки снизу вверх
В качестве цифр 16-ой системы счисления используются цифры от 0 до 9 и латинские буквы от A до F.
А = 10₁₀ B = 11₁₀ C = 12₁₀ D = 13₁₀ E = 14₁₀ F = 15₁₀
142₁₀ = 8Е₁₆
Переведите число D3₁₆ по схеме А16 → А10 → А8
D3₁₆ = D * 16¹ + 3 * 16⁰ = 13 * 16 + 3 * 1 = 211₁₀
В качестве цифр 16-ой системы счисления используются цифры от 0 до 9 и латинские буквы от A до F.
А = 10₁₀ B = 11₁₀ C = 12₁₀ D = 13₁₀ E = 14₁₀ F = 15₁₀
D3₁₆ = 211₁₀
211 / 8 = 26 + остаток 3
26 / 8 = 3 + остаток 2
3 / 8 = 0 + остаток 3
записываем остатки снизу вверх
211₁₀ = 323₈
254₈ = 172₁₀ = АС₁₆
9F₁₆ = 159₁₀ = 237₈
Объяснение:
Переведите число 254₈ по схеме А8 → А10 → А16
254₈ = 2 * 8² + 5 * 8¹ + 4 * 8⁰ = 2 * 64 + 5 * 8 + 4 * 1 = 128 + 40 + 4 = 172₁₀
254₈ = 172₁₀
172 / 16 = 10 + остаток 12 (С)
10 / 16 = 0 + остаток 10 (А)
записываем остатки снизу вверх
В качестве цифр 16-ой системы счисления используются цифры от 0 до 9 и латинские буквы от A до F.
А = 10₁₀ B = 11₁₀ C = 12₁₀ D = 13₁₀ E = 14₁₀ F = 15₁₀
172₁₀ = АС₁₆
Переведите число 9F₁₆ по схеме А16 → А10 → А8
9F₁₆ = 9 * 16¹ + F * 16⁰ = 9 * 16 + 15 * 1 = 144 + 15 = 159₁₀
В качестве цифр 16-ой системы счисления используются цифры от 0 до 9 и латинские буквы от A до F.
А = 10₁₀ B = 11₁₀ C = 12₁₀ D = 13₁₀ E = 14₁₀ F = 15₁₀
9F₁₆ = 159₁₀
159 / 8 = 19 + остаток 7
19 / 8 = 2 + остаток 3
2 / 8 = 0 + остаток 2
записываем остатки снизу вверх
159₁₀ = 237₈