1.Составьте программу, которая вставляет заданной слово z после указанного слова t строки s.Строки s, t, z вводится с клавиатуры. 2) С клавиатуры вводится строка, содержащаяся русские буквы и цифры. Составьте программу, позволяющую найти количество:
a) цифр в строке
б) букв в строке
3)Составьте программу, которая выводит на экран последовательность кодов введенной с клавиатуры строки. Узнайте, как будет выглядеть кодировки вашего имени(Карина)
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
var fam:=ReadlnString('Фамилия:');
var nam:=ReadlnString('имя:');
var otch:=ReadlnString('отчество:');
var fio:=fam+' '+nam+' '+otch;
Writeln(fio,', длина текста- ',fio.Length)
end.
Тестовое решение
Фамилия: Иванов
имя: Сергей
отчество: Петрович
Иванов Сергей Петрович, длина текста- 22
Задание 3)
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
var w:='ИНТЕГРАЛ';
Writeln(w[5]+w[7]+w[2:5]+w[8]+w[1]);
Writeln(w[6]+w[4]+w[2:4]+w[5:3:-1]+w[2]);
Writeln(w[3]+w[1]+w[5:7]);
Writeln(w[7]+w[5:3:-1]+w[2:4]);
Writeln(w[6:]+w[8]+w[1]);
Writeln(w[1]+w[5:8]);
Writeln(w[2::-1]+w[3]+w[6:8]+w[3])
end.
Решение:
ГАНТЕЛИ
РЕНТГЕН
ТИГР
АГЕНТ
РАЛЛИ
ИГРА
НИТРАТ
uses System;
uses System.Collections;
begin
var d := DateTime.Today;
repeat
d := d.AddDays(1);
until d.DayOfWeek = DayOfWeek.Sunday;
var Sundays := new Dictionary<integer, integer>();
repeat
if Sundays.ContainsKey(d.Year) then
Sundays[d.Year] += 1
else
Sundays.Add(d.Year, 1);
d := d.AddDays((-7));
until d.Year <= 1;
var max := Sundays.Values.Max;
Sundays.Where(x -> x.Value = max).Println;
end.