В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ефим30
ефим30
29.07.2022 18:31 •  Информатика

1. Составить программу ввода с клавиатуры шести чисел и нахождения суммы тех из них, которые больше 4. 2. Дан массив целых чисел А, состоящий из 7 элементов. Заполнить его с клавиатуры. Найти произведение положительных элементов массива.

Показать ответ
Ответ:
cvvb
cvvb
15.10.2020 13:04
                                     PascalABC.NET                                       beginPrintln('Результат:',ReadArrInteger(6).Sum(x->x>4?x:0));Println('Результат:',ReadArrInteger(7).Product(x->x>0?x:1));end.

Первая строчка -- первое задание, вторая -- второе.

Пример работы:


1. Составить программу ввода с клавиатуры шести чисел и нахождения суммы тех из них, которые больше
0,0(0 оценок)
Ответ:
Макс528103
Макс528103
15.10.2020 13:04

1.

var arr: array[1..6] of integer;

var i, summ: integer;

begin

 summ:= 0;

 for i:=1 to 6 do

 begin

   readln(arr[i]);

 end;

   

 for i:=1 to 6 do

   begin

       if arr[i]>4 then

           summ := summ+arr[i];

   end;

   

 writeln(summ);

end.

var arr: array[1..7] of integer;

var i, mult: integer;

begin

 mult:= 1;

 for i:=1 to 7 do

 begin

   readln(arr[i]);

 end;

   

 for i:=1 to 7 do

   begin

       if arr[i]>0 then

           mult := mult*arr[i];

   end;

   

 writeln(mult);

end.

Краткий гайд

i - переменная-счётчикarr - массив, с которым производятся операцииsumm - (в первом задании - переменная, отвечает за сумму элементовmult - (во второй части) отвечает за произведение
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота