В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
savikdaniil3
savikdaniil3
03.03.2020 08:49 •  Информатика

1)составить программу. определяющуя является ли веденное слово перевертышем. входные данные: ввести строку s с длинной не более 255 символов. выходные данные: вывести количество содержащихся в ней прописных латинских букв. 2)дана строка, состоящая из слов, набранных заглавными буквами и разделенных пробелами (одним или несколькими). найти количество слов, которые начинаются и заканчиваются одной и той же буквой.

Показать ответ
Ответ:
niga24
niga24
12.06.2020 12:29

var

  s : string;

  i : integer;

  f : boolean;

begin

  readln (s);

  writeln ('Тут ', length (s), ' символов');

  f := true;  

for i := 1 to length (s) div 2 do

    if s[i] <> s[length (s) - i + 1] then f := false;

  writeln ('Это слово является перевертышем: ', f); //True/False

end.

 

var

  s : string;

  i, k, count : integer;

  c : char;

begin

  readln (s);

  count := 0;

  for i := 1 to length (s) do

    if s[i] <> ' ' then

    begin

       c := s[i];

       k := i + 1;

       break;

    end;

  for i := k to length (s) do

    if (s[i] = ' ') and (c <> ' ') then

    begin

       if s[i - 1] = c then inc (count);

       c := ' ';

    end

    else if c = ' ' then c := s[i];

  if (c <> ' ' ) and (s[length (s)] <> ' ') and (c = s[length (s)]) then inc (count);

  writeln (count);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота