В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Arina200531
Arina200531
09.05.2021 11:33 •  Информатика

1. Составить программу нахождения суммы чисел от 1 до 50 и вывода на экран полученного результата. 2. Найдите ошибки в программе и исправьте их:

Program z2

Var a, b, s: integer;

Begin;

A=10;

B:=6

S:=A+B;

Writeln (S;

End

3. Составить программу нахождения произведения чисел от 1 до 5 с оператором While.

4. Составить программу нахождения произведения чисел от 1 до 5 с оператором For.

Показать ответ
Ответ:
yaltalove67
yaltalove67
15.08.2020 00:40

Ну начнем с того, что твоя функция ничего не возвращает, она выводит на экран информацию. Второй косяк в том, что функция isdigit() проверяет всю строку, то есть, при строке с одними цифрами твоя программа даст верный ответ.

Исправить максимально просто, нам нужно проверить каждый символ строки, если встречаем хоть 1 цифру, то возвращаем true, а если не встретим в строке цифр - false.

Максимально простой вариант для новичка, скорее всего, такой:

def number(x):

  for i in x:

      if i.isdigit():

          return True

  return False

print(number('xx'))

0,0(0 оценок)
Ответ:
Yarina0311
Yarina0311
31.03.2023 18:54

Паша имеет выйгрушную стратегию и сможет выйграть за один ход, если s=27 тогда ему достаточно добавить один камень чтобы игра закончилась при 28 камнях в куче или если s=14,15,16,17,18,19,20,21,22(44/2 и 28/2 т.е от 14 до 22), тогда не обходимо удвоить количество камней в куче.

Объяснение:

Паша имеет выйгрушную стратегию и сможет выйграть за один ход, если s=27 тогда ему достаточно добавить один камень чтобы игра закончилась при 28 камнях в куче или если s=14,15,16,17,18,19,20,21,22(44/2 и 28/2 т.е от 14 до 22), тогда не обходимо удвоить количество камней в куче.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота