В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nikitleas
nikitleas
18.03.2023 05:41 •  Информатика

1.Составить программу, которая выводит сообщение о своих возможностях : Введите номер необходимой функции:
1-квадрат; 2-корень квадратный; 3-синус; 4-косинус
и считает соответствующую функцию для введённого с клавиатуры числа.

Показать ответ
Ответ:
nikk72827
nikk72827
29.12.2020 22:38

#include <iostream>

#include <cmath>

#include <conio.h>

using namespace std;

int main() {

   cout << "Введите номер необходимой функции:\n1-квадрат; 2-корень квадратный; 3-синус; 4-косинус\n";

   char c;

   cin >> c;

   // Если используешь обычный компилятор (не онлайн), можно написать "char c = _getch()";

   

   cout << "Введите число: \n";

   int num;

   cin >> num;

   

   switch(c) {

       case '1':

           cout << pow(num ,2);

           break;

       case '2':

           cout << sqrt(num);

           break;

       case '3':

           cout << sin(num);

           break;

       case '4':

           cout << cos(num);

           break;

       default:

           cout << "Ошибка ввода";

   }

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота