1. Составить программу для вычисления значений функций F(x) на отрезке [a,b] с шагом h. Результат представить в виде таблицы, первый столбец - значение аргумента, второй - значение функции. Выполнить проверку ввода: a F(x)=x-sinx
2. Написать программу, которая определяет максимальное положительное число из введенной с клавиатуры последовательности чисел(длина последовательности неограниченна, заканчивается 0).
#include <iostream>
using namespace std;
int main() {
double shop1, shop2, shop3,money1, money2, money3;
double day, max, maxday;
cout << "Введите доход первого магазина: ";
cin >> shop1;
cout << "Введите доход второго магазина: ";
cin >> shop2;
cout << "Введите доход третего магазина: ";
cin >> shop3;
day = 10;
if(shop1 < shop2 and shop2 > shop3){
maxday = 2;
}
else if(shop2 < shop1 and shop1 > shop3){
maxday = 1;
}
else if(shop1 < shop3 and shop3 > shop2){
maxday = 3;
}
for (int i = 1; i < day; i++) {
for (int i1 = 0; i1 <= day; i1++) {
money1 = shop1 + money1;
}
for (int i2 = 0; i2 <= day; i2++) {
money2 = shop2 + money2;
}
for (int i3 = 0; i3 <= day; i3++) {
money3 = shop3 + money3;
}
}
if(money1 < money2 and money2 > money3){
max = money2;
cout << "Максималная доход второго магазина: " << shop2 << " за "<< 1 << " ден\n";
cout << "Максималная доход второго магазина: " << max << " за "<< day << " дней";
return 0;
}
else if(money2 < money1 and money1 > money3){
max = money1;
cout << "Максималная доход первого магазина: " << shop1 << " за "<< 1 << " ден\n";
cout << "Максималная доход первого магазина: " << max << " за "<< day << " дней";
return 0;
}
else if(money1 < money3 and money3 > money2){
max = money3;
cout << "Максималная доход третего магазина: " << shop3 << " за "<< 1 << " ден\n";
cout << "Максималная доход третего магазина: " << max << " за "<< day << " дней";
return 0;
}
}
Объяснение:
Объяснение:
#include <iostream>
using namespace std;
int main()
{
int kol, napr;
char sim;
cout << "Vvedite kolichestvo" << endl;
cin >> kol;
cout << endl << "Vvedite simvol" << endl;
cin >> sim;
char massiv[kol];
for(int i = 0; i < kol; i ++)
massiv[i] = sim;
cout << endl << "1 - gorizontalno" << endl << "2 - vertikalno" << endl;
cin >> napr;
if(napr == 1){
int i = 0;
while(i != kol){
cout << massiv[i];
i++;
}
}
if(napr == 2){
int i = 0;
while(i != kol){
cout << massiv[i] << endl;
i++;
}
}
return 0;
}