В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

1.составить программу для определения принадлежности точки заданной области pascal 2. сгенерировать элементы массива целого типа случайным образом в заданном диапазоне [a,b] согласно варианту a= -22 b=132 найти среди элементов массива минимальный элемент.

Показать ответ
Ответ:
estvolygina
estvolygina
24.07.2020 11:50

Объяснение:

procedure F(n: integer);

begin

 if n>0 then begin

   Write (n);

   F(n-2);

   F(n div 4);

   end

end;

begin

 F(9);

end.

На выходе будет 97531112

Если нужна трассировка, её можно сделать примерно так:

procedure F(n: integer);

begin

 Writeln('Вход');

 if n>0 then begin

   Writeln ('В выходную строку: ',n);

   Writeln('Вызов F(n-2)');

   F(n-2);

   Writeln('Вызов F(n div 4)');

   F(n div 4);

   end;

   Writeln('Выход')

end;

begin

 F(9);

end.

Результат трассировки:

Вход

В выходную строку: 9

Вызов F(n-2)

Вход

В выходную строку: 7

Вызов F(n-2)

Вход

В выходную строку: 5

Вызов F(n-2)

Вход

В выходную строку: 3

Вызов F(n-2)

Вход

В выходную строку: 1

Вызов F(n-2)

Вход

Выход

Вызов F(n div 4)

Вход

Выход

Выход

Вызов F(n div 4)

Вход

Выход

Выход

Вызов F(n div 4)

Вход

В выходную строку: 1

Вызов F(n-2)

Вход

Выход

Вызов F(n div 4)

Вход

Выход

Выход

Выход

Вызов F(n div 4)

Вход

В выходную строку: 1

Вызов F(n-2)

Вход

Выход

Вызов F(n div 4)

Вход

Выход

Выход

Выход

Вызов F(n div 4)

Вход

В выходную строку: 2

Вызов F(n-2)

Вход

Выход

Вызов F(n div 4)

Вход

Выход

Выход

Выход

0,0(0 оценок)
Ответ:
Kirill91623
Kirill91623
04.11.2021 18:56

Объяснение:Решение.

Знаком ~ обозначается операция эквивалентности (результат X ~ Y — истина, если значения X и Y совпадают).

Введем обозначения:

 

(x ∈ P) ≡ P; (x ∈ Q) ≡ Q; (x ∈ A) ≡ A.

 

Тогда, применив преобразование импликации, получаем:

 

¬(P ~ Q) ∨ ¬A ⇔ ¬(P ~ Q) ∨ ¬A = 1.

 

Выражение ¬(P ~ Q) истинно только тогда, когда x ∈ [5; 14) и x ∈ (23; 30] (см. рисунок). В таком случае, для того, чтобы выражение было истинно при любом x, A должно лежать либо в промежутке [5; 14), либо (23; 30]. Следовательно, наибольшая возможная длина промежутка равна 14 − 5 = 9.

 

ответ: 9.

ответ правельный чесное слово нажми

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота