1. Служебное слово VAR в программе на языке Pascal фиксирует начало раздела программы, содержащего:
А) операторы;
Б) список меток;
В) описание сложных типов данных;
Г) перечень констант;
Д) описание переменных.
2. Числа в языке Pascal различаются:
А) как натуральные и целые;
Б) как целые и вещественные;
В) как натуральные и вещественные;
Г) как целые и иррациональные;
Д) как целые и рациональные.
3. Оператор организации ввода данных с клавиатуры в системе программирования Turbo Pascal записывается с использованием служебного слова:
А) WRITE; Б) INPUT; В) READ; Г) DEFFN; Д) RESET.
4. Комментарий к тексту программы на языке Pascal заключается:
А) в фигурные скобки;
Б) в круглые скобки;
В) в квадратные скобки;
Г) в апострофы;
Д) между служебными словами Begin, End.
5. Служебное слово BEGIN в программе на языке Pascal фиксирует начало раздела программы, содержащего:
А) перечень констант;
Б) действия программы;
В) описание переменных;
Г) операторы;
Д) описание сложных типов данных.
6. При записи оператора вывода на языке Pascal используется служебное слово:
А) WRITE; Б) RESET;
В) READ; Г) BEGIN; Д) WHILE
7. Операторы в программе на языке Pascal отделяются друг от друга:
А) апострофом; Б) двоеточием;
В) пробелом; Г) запятой; Д) точкой с запятой.
8. Дана программа:
Program T21;
Var X: Integer;
Begin
Read (X);
If X MOD 2=0 Then Writeln(‘ДА’)
Else Writeln(‘НЕТ’)
End.
При каком значении X будет получен ответ “ДА”?
А) 7; Б) 4; В) 15; Г) 3; Д) 21.
9. В каком из условных операторов допущена синтаксическая ошибка?
а) if B = 0 then Writeln ('Деление на нуль невозможно.');
б) if a > b then m:= a else m:= b;
в) if a>b then c:=a+b; г) if a < b then min:= a; else min:= b;
10. В алфавит языка Pascal входит следующее слово:
а) bigin; б) begin; в) begun.
11. Операторные скобки на языке Pascal заключается:
а) в круглые скобки;
б) в фигурные скобки;
в) в квадратные скобки;
г) между служебными словами begin и end.
12. Какое значение примет переменная X после выполнения операторов:
A:=4;
X;=sgrt(A);
If x<>2 then x:=x*3 else x:=5+x;
ответ
13. Определите значение переменной c после выполнения следующего фрагмента программы:
a := -2;
b := -3;
a := b + a*3;
if a < b then
c := a - b
else c := b - a;
ответ
14. Определите значение переменной c после выполнения следующего фрагмента программы:
a := 40;
b := 10;
b := a - 2*b;
if a < 2*b then
c := a
else c := b;
ответ
15. Дан алгоритм:
Read (x);
if x<-20 then y = 2 * x ;
if x<=100 then y = 51 ;
if x>10 then y = x ;
Write (y);
Какое число будет выведено в результате выполнения алгоритма, если ввести значение X = -22?
ответ
В восьмиричной системе: разбиваете двоичное представление на группы по 3 бита справа налево
011 = 3
011 = 3
011 = 3
10 = 2
Тогда в восьмиричной системе: 2333(8) = 2*8^3+3*8^2+3*8^1+3 = 1024+192+24+3=1243(10)
В шестнадцатиричной системе: разбиваете двоичное представление на группы по 4 бита справа налево
1011 = B = 11(10)
1101 = D(16) = 13(10)
100 = 4
Тогда в шестнадцатиричной системе
4DB(16) = 4*16^2+13*16^1+11 =1024+208+11=1243(10)
z:string[10];
x:string[2];
i,j,k,m: integer; //новые переменные
Begin
Write('введите строку текста - St');
Readln(St);
k:=0; //обнуляем на всякий случай
z:='0123456789';
i:=1;
for j:=1 to length(St) do //начало
begin;
for m:=1 to 10 do
if St[j]=z[m] then inc(k);
end;
if k=0 then
begin;
writeln('в тексте нет цифр');
exit;
end; //конец
while i<=length(st)-1 do
begin
x:=copy(st,I,2);
if (x[1]=x[2]) and (pos(x[1],z)<>0) then
begin
delete(st,i,2);
insert('две',st,i);
i:=i+1;
end;
i:=i+1;
end;
writeln('преобразованная строка ', st);
End.