1. Үш өлшемді графиканы құру мен редакциялау үшін қандай программалық орта қолданылады? 2. SketchUp программасының қандай мүмкіндіктерін білесіңдер? 3. Sketch-Up программасын қалай іске қосуға болады?
Схе́ма Го́рнера (или правило Горнера, метод Горнера, метод Руффини-Горнера) — алгоритм вычисления значения многочлена, записанного в виде суммы мономов (одночленов), при заданном значении переменной. Метод Горнера позволяет найти корни многочлена[1], а также вычислить производные полинома в заданной точке. Схема Горнера также является простым алгоритмом для деления многочлена на бином вида {\displaystyle x-c}x-c. Метод назван в честь Уильяма Джорджа Горнера, однако Паоло Руффини опередил Горнера на 15 лет, а китайцам этот был известен еще в XIII веке.
Var i,j,n:integer; m: array[1..10,1..10] of integer; flag:boolean; sum: array[0..1] of longint; begin readln(n); flag:=true; for i:=1 to n do begin for j:=1 to n do read(m[i,j]); readln; end; //Проверяем строки i:=1; for j:=1 to n do sum[i mod 2]:=sum[i mod 2]+m[i,j]; while ((i<n) and flag) do begin i:=i+1; for j:=1 to n do sum[i mod 2]:=sum[i mod 2]+m[i,j]; if sum[0]<>sum[1] then flag:=false; sum[(i+1) mod 2]:=0; end; //Проверяем столбцы sum[0]:=0; sum[1]:=0; j:=1; for i:=1 to n do sum[j mod 2]:=sum[j mod 2]+m[i,j]; while ((j<n) and flag) do begin j:=j+1; for i:=1 to n do sum[j mod 2]:=sum[j mod 2]+m[i,j]; if sum[0]<>sum[1] then flag:=false; sum[(j+1) mod 2]:=0; end; sum[0]:=0; sum[1]:=0; j:=1; for i:=1 to n do begin sum[0]:=sum[0]+m[i,j]; sum[1]:=sum[1]+m[n-i+1,j]; j:=j+1; end; if sum[0]<>sum[1] then flag:=false; if flag then writeln('Магический'); end.
Объяснение:
Схе́ма Го́рнера (или правило Горнера, метод Горнера, метод Руффини-Горнера) — алгоритм вычисления значения многочлена, записанного в виде суммы мономов (одночленов), при заданном значении переменной. Метод Горнера позволяет найти корни многочлена[1], а также вычислить производные полинома в заданной точке. Схема Горнера также является простым алгоритмом для деления многочлена на бином вида {\displaystyle x-c}x-c. Метод назван в честь Уильяма Джорджа Горнера, однако Паоло Руффини опередил Горнера на 15 лет, а китайцам этот был известен еще в XIII веке.
i,j,n:integer;
m: array[1..10,1..10] of integer;
flag:boolean;
sum: array[0..1] of longint;
begin
readln(n);
flag:=true;
for i:=1 to n do
begin
for j:=1 to n do
read(m[i,j]);
readln;
end;
//Проверяем строки
i:=1;
for j:=1 to n do
sum[i mod 2]:=sum[i mod 2]+m[i,j];
while ((i<n) and flag) do
begin
i:=i+1;
for j:=1 to n do
sum[i mod 2]:=sum[i mod 2]+m[i,j];
if sum[0]<>sum[1] then flag:=false;
sum[(i+1) mod 2]:=0;
end;
//Проверяем столбцы
sum[0]:=0;
sum[1]:=0;
j:=1;
for i:=1 to n do
sum[j mod 2]:=sum[j mod 2]+m[i,j];
while ((j<n) and flag) do
begin
j:=j+1;
for i:=1 to n do
sum[j mod 2]:=sum[j mod 2]+m[i,j];
if sum[0]<>sum[1] then flag:=false;
sum[(j+1) mod 2]:=0;
end;
sum[0]:=0;
sum[1]:=0;
j:=1;
for i:=1 to n do
begin
sum[0]:=sum[0]+m[i,j];
sum[1]:=sum[1]+m[n-i+1,j];
j:=j+1;
end;
if sum[0]<>sum[1] then flag:=false;
if flag then writeln('Магический');
end.