В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vanya2155
Vanya2155
09.12.2020 09:00 •  Информатика

1)Программа
WRITE (‘Введи два числи’);
READ (А,В);
IF A>B THEN S:= A ELSE S:=B;
WRITE (S);
Входные данные:12,15
2)WRITE (‘Введите число’);
READ ( X);
IF X<=10 THEN Y:=210 ELSE Y:=X*X*X ;
WRITE (Y);
Входные данные:5

Показать ответ
Ответ:
Aann1
Aann1
28.09.2020 14:19
Вот задача для "троечников" с дополнительной оценкой:

program pr1;
uses
crt;

const
arr1 : array[1..12] of integer = (5, 4, -3, 1, 0, -4, 0, 25, -8, 0, -17, -1);

type
arr2 = array of integer;

var
arr : arr2;
n : integer;
i, sot, spl, snu : byte;
ch : char;

begin
write('Хотите использовать заданный по умолчанию массив? (y/n): ');
ch := readkey;
writeln(ch);
sot := 0;
spl := 0;
snu := 0;
if ((ch='y') or (ch='Y')) then begin
{ Используем заданный по умолчанию }
for i:=1 to 12 do begin
if arr1[i] > 0 then inc(spl);
if arr1[i] < 0 then inc(sot);
if arr1[i] = 0 then inc(snu);
write(arr1[i], ' ');
end;
writeln;
end
else begin
{ Создаём и заполняем новый массив }
write('Введите желаемый размер массива: ');
readln(n);
setLength(arr, n);
writeln('Введите элементы массива:');
for i:=0 to high(arr) do
readln(arr[i]);
for i:=0 to high(arr) do begin
if arr[i]>0 then inc(spl);
if arr[i]<0 then inc(sot);
if arr[i]=0 then inc(snu);
write(arr[i], ' ');
end;
writeln;
end;

writeln('Количество отрицательных элементов: ', sot);
writeln('Количество нулевых элементов: ', snu);
writeln('Количество положительных элементов: ', spl);
end.
0,0(0 оценок)
Ответ:
alinamalina37544
alinamalina37544
07.05.2022 01:43

#include <iostream>

using namespace std;

int main() {

int a, b, c;

//Введем значение трех переменных

cin >> a >> b >> c;

//Направим указатели

int* pa = &a;

int* pb = &b;

int* pc = &c;

cout << "a=" << a << " b=" << b << " c=" << c<<endl;

//Увеличим в два раза

*pa *= 2;

*pb *= 2;

*pc *= 2;

cout << "a=" << a << " b=" << b << " c=" << c<<endl;

//Поменяем местами с и b

*pc += *pb;

*pb = *pc - *pb;

*pc = *pc - *pb;

cout << "a=" << a << " b=" << b << " c=" << c<<endl;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота