В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sofiyasan7
sofiyasan7
24.02.2022 15:58 •  Информатика

1. Проанализируйте программу, представленную ниже. Какое число будет выведено на экран, если массив состоит из
чисел [1,2,3,4,5]?
const n = 5;
var
a: array [1..n] of integer;
s, i: integer;
begin
s:=0;
write('Введите элементы массива: ');
for i:=1 to N do
readln(a[i]);
for i:=1 to N do
s:=s+a[i];
writeln(s);
end.
2. Напишите программу, выводящую на экран произведение всех
элементов массива A(n). Для написания программы подходит
блокнот, имеющийся на любой версии ОС компьютера, или на
языке программирования PascalABC.NET( )

Показать ответ
Ответ:
Fedotaq
Fedotaq
27.11.2020 20:11

var

 sum, a, b, c: real;

begin

 Write('Введите количество масла в кг.: ');

 Read(a);

 Write('Введите количество сметаны в кг.: ');

 Read(b);

 Write('Введите количество сливок в кг.: ');

 Read(c);

 sum := a * 188.5;

 Writeln('За ', a, 'кг. масла, получится: ', sum, 'р.');

 sum := b * 95;

 Writeln('За ', b, 'кг. сметаны, получится: ', sum, 'р.');

 sum := c * 104.5;

 Writeln('За ', c, 'кг. сливок, получится: ', sum, 'р.');

 Writeln('Общая сумма: ', (a * 188.5) + (b * 95) + (104.5), 'р.');

end.

Тестовое решение:

Введите количество масла в кг.: 6

Введите количество сметаны в кг.: 4

Введите количество сливок в кг.: 2

За 6кг. масла, получится: 1131р.

За 4кг. сметаны, получится: 380р.

За 2кг. сливок, получится: 209р.

Общая сумма: 1615.5р.

0,0(0 оценок)
Ответ:
Вася2288221
Вася2288221
15.12.2020 04:35

Условие: (x % 4 == 0 and x % 100 != 0) or x % 400 == 0

Рассмотрим скобку x % 4 == 0 and x % 100 != 0:

x % 4 == 0 — число делится на 4 без остатка, т.е. кратно 4-мx % 100 != 0 — число не делится на 100 без остатка, т.е. не кратно 100

and говорит о том, что обязательно должны выполняться оба этих условия: число должно быть кратно 4-м И не кратно 100

Вторая часть условия:

x % 400 == 0 — число делится на 400 без остатка, т.е. кратно 400

or говорит о том, что либо выполняется условие в скобке, либо то, которое идет после or:

число должно быть кратно 4-м И не кратно 100, ИЛИ число должно быть кратно 400

Пример чисел, которые удовлетворяют условию:

0

4

8

12

128

400

1600

Например, 200 не подойдет:

200 % 4 == 0 — да

200 % 100 != 0 — нет

200 % 400 == 0 — нет

(да И нет) ИЛИ нет = нет ИЛИ нет = нет

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота